Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop FF from opening my downloaded documents in the browser

  • 4
  • 1 nwere nsogbu anwere nsogbu a
  • 3 views
  • Nzaghachi ikpeazụ nke rcalldr

more options

Hello,

In the past, FF downloaded documents without opening them in the browser. This is two weeks now that whenever I download a document, FF is now opening the document in the browser without asking me.

I welcome if someone could tell me what I can do to stop FF from opening the documents.

Thanks for any help you can offer me.

Hello, In the past, FF downloaded documents without opening them in the browser. This is two weeks now that whenever I download a document, FF is now opening the document in the browser without asking me. I welcome if someone could tell me what I can do to stop FF from opening the documents. Thanks for any help you can offer me.

Edeziri site na NoahSUMO

Asịsa ahọpụtara

Hi, if "Portable Document Format (PDF)" is set to Save File, then Firefox should not open the PDF. If it is set to another option, then Firefox will download/save the file and then either open it in a tab ("Open in Firefox" option) or open it in another program (for example, "Use Adobe Acrobat"). If that last part isn't working, hmm, is Firefox opening it from a file:/// address, or on the original site?

Gụọ azịza a na nghọta 👍 0

All Replies (4)

more options

Hi, is this a problem with PDFs? You can control what Firefox does when you download a PDF with the Application settings. This article will get you in there: View PDF files in Firefox or choose another viewer.

If other kinds of files are affected, hmm, Firefox can't render most kinds of documents. Does it look like the download page is generating a PDF preview of the document?

Helpful?

more options

Hello jscher2000,

Thanks for your effort to help me solve the problem on my hands.

So far, I only have this problem with PDFs on the download page.

Since I received your response, I followed the steps in the article at the end of the link you provided.

The good news is that I followed all the steps, and selected the PDF viewer I wanted as my default, but I didn’t see any save or okay or update button to change the settings.

After I selected the PDF viewer I wanted, I downloaded a PDF, but FF continued to open the PDF.

If I did something wrong, and you realize it, do let me know.

Again, thanks very much.

Helpful?

more options

Asịsa Ahọpụtara

Hi, if "Portable Document Format (PDF)" is set to Save File, then Firefox should not open the PDF. If it is set to another option, then Firefox will download/save the file and then either open it in a tab ("Open in Firefox" option) or open it in another program (for example, "Use Adobe Acrobat"). If that last part isn't working, hmm, is Firefox opening it from a file:/// address, or on the original site?

Helpful?

more options

Hello jsher2000,

Thanks for all your help. Without your instructions, I know I would still be in the dark. Finally, I got FF to only download and save the PDF, no more opening it.

Again, thanks for your help, and have a great rest of the week.

Helpful?

Jụọ ajụjụ

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.