On Monday September 25th from 10PM EDT - 12AM EDT (2AM UTC - 4AM UTC on September 26th), we will be performing system maintenance on the Firefox Accounts databases for two hours. During the maintenance window, there will be brief periods of a few minutes where users will not be able to login to their accounts. Please try again at a later time.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to default to my extensions when open Extensions (about:addons)?

more options

When I open "Extensions" (about:addons) by clicking the Extensions icon, I want it to start on my own extensions, not Recommendations. How can I make "Extensions" open to the actual Extensions tab? Or can I remove the "Recommendations" tab entirely?

I already saw [to remove 'Recommendations' tab in about:addons]. But about:config

 extensions.htmlaboutaddons.recommendations.enabled = false

only removes recommendations from the Extensions tab. And adding

 extensions.getAddons.showPane = false

does not work, the Recommendations tab is still there.

When I open "Extensions" (about:addons) by clicking the Extensions icon, I want it to start on my own extensions, not Recommendations. How can I make "Extensions" open to the actual Extensions tab? Or can I remove the "Recommendations" tab entirely? I already saw [[https://support.mozilla.org/en-US/questions/1374160|How to remove 'Recommendations' tab in about:addons]]. But about:config extensions.htmlaboutaddons.recommendations.enabled = false only removes recommendations from the Extensions tab. And adding extensions.getAddons.showPane = false does not work, the Recommendations tab is still there.
Nseta ihuenyo ndị agbakwunyere

Asịsa ahọpụtara

Try to set both these prefs to false and make sure that the Recommendations tab isn't selected and close all tabs with the about:addons page (you may still have to reload the about:addons page via F5).

  • extensions.getAddons.showPane = false
  • extensions.getAddons.cache.enabled = false
  • extensions.ui.lastCategory (click the trash can)
Gụọ azịza a na nghọta 👍 1

All Replies (2)

more options

Asịsa Ahọpụtara

Try to set both these prefs to false and make sure that the Recommendations tab isn't selected and close all tabs with the about:addons page (you may still have to reload the about:addons page via F5).

  • extensions.getAddons.showPane = false
  • extensions.getAddons.cache.enabled = false
  • extensions.ui.lastCategory (click the trash can)

Helpful?

more options

I did those steps and found by accident that it sometimes works and sometimes does not. When I have all extensions pinned to the toolbar, clicking the Extensions icon immediately opens the Extensions page (about:addons). In that case, the Recommendations tab still shows and is still the default. If I have any extensions enabled but not pinned, then clicking the Extensions icon expands a dropdown showing the un-pinned extensions, and I have to click "Manage extensions" at the bottom. In that case, the Extensions page does not show the Recommendations tab and defaults to the Extensions tab.

When the Recommendations tab is still there, pressing F5 doesn't help. But if I select the Extensions tab first, then press F5, the Recommendations tab disappears. The first two keys you listed are still false, but the third comes back. When Recommendations tab is present that key's value is "addons://discover/". After Recommendations disappears, the key's value changes to "addons://list/extension". Unfortunately, for the case where clicking the Extensions icon immediately opens the Extensions page, the Recommendations tab always comes back and is the default.

Crazy part: When Recommendations tab is already gone and Extensions tab is selected, pressing F5 shows the Recommendations tab header reappear for an instant, then disappear! Pressing F5 repeats this each time. Fun bugs!

I'm going to just keep an extension un-pinned and call it solved. Thanks. (BTW, it would be great if you could add that note to your solution for other people who don't read the thread.) Leave the rest for Mozilla to fix... if they get around to it...

Edeziri site na timepilot3000

Helpful?

Jụọ ajụjụ

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.