Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Send tab to device" only shows 4 most recent devices

  • 5
  • 4
  • 100 views
  • Nzaghachi ikpeazụ nke Darren

more options

When using "send tab to device", the submenu previously showed all synced devices, in my case, more than 10 devices. Recently it only shows 4 devices and there is no way to access the other ones. Is this broken or is it a recent change? If so, can I revert the behavior with a preference?

Under "manage devices", I still see all of my synced devices, they just don't show up in the "send to device" submenu.

When using "send tab to device", the submenu previously showed all synced devices, in my case, more than 10 devices. Recently it only shows 4 devices and there is no way to access the other ones. Is this broken or is it a recent change? If so, can I revert the behavior with a preference? Under "manage devices", I still see all of my synced devices, they just don't show up in the "send to device" submenu.

Asịsa ahọpụtara

I notice the same issue a few days ago with 109, but after a few days sync is now current. see screenshot You can also look at your sync tab and you'll see the same issue. This is why I run multiple browsers, just in case an update goes BOOM. Install waterfox or a previous version of firefox and you'll see all of your devices until 109 is current.

Gụọ azịza a na nghọta 👍 0

All Replies (5)

more options

Asịsa Ahọpụtara

I notice the same issue a few days ago with 109, but after a few days sync is now current. see screenshot You can also look at your sync tab and you'll see the same issue. This is why I run multiple browsers, just in case an update goes BOOM. Install waterfox or a previous version of firefox and you'll see all of your devices until 109 is current.

Edeziri site na jonzn4SUSE

more options

Thanks for that. I did notice a few days or a week ago that synced tabs from some devices were not showing on my iphone. Now I see that it has spread to the desktop. Let's hope this saorts itself out automatically as you say. I rely heavily on sync and sending tabs across devices.

more options

It seems they don't come back on their own. I have to go to each missing computer and give it is kick. It seems just pressing the manual sync button doesn't do it either. Sending a tab from the missing computer to the computer where it is missing seems to do the trick (major pain though).

more options

https://support.mozilla.org/en-US/questions/1403774#answer-1563909 This user had a similar issue and it took time for sync to... sync.  ;-)

more options

I guess the missing device has to be on and has to push a new sync to show up. It's not enough to be a "connected device" on your sync mamagement page. I used to be able to send tabs to devices that were off, then when the device turned on, the tab would appear.

I guess the update wiped out the list of synced devices and they don't come back until you actually sync them.