Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDF VIEWER

more options

I'm using 107.0.1 vers. At this link it states: https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-or-choose-another-viewer#w_use-a-different-pdf-viewer-for-downloaded-pdf-files

Disable the built-in PDF viewer and use another viewer

You can also set a different third-party PDF viewer to handle PDF files, instead of Firefox’s built-in PDF viewer. To switch from using the built-in PDF viewer to another viewer: 1. Click the menu button and select . 2. In the panel, go down to the Applications section. (SO WHERE IN THE HELL IS THIS SECTION???) YOU CAN'T DO I never selected Mozilla to open any pdf and there's no where to opt out or change based on what all the troubleshooting tips say... All these tips must be located on a much older version of Firefox cause they ain't in my version OR they are hid under some dubious section... Pretty frustrating....when you want to use Adobe and can't cause I'm locked in under Firefox....don't know how that has happened unless it was done automatically under one of the many current upgrades that have been coming down over the last month.

I'm using 107.0.1 vers. At this link it states: https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-or-choose-another-viewer#w_use-a-different-pdf-viewer-for-downloaded-pdf-files '''Disable the built-in PDF viewer and use another viewer''' You can also set a different third-party PDF viewer to handle PDF files, instead of Firefox’s built-in PDF viewer. To switch from using the built-in PDF viewer to another viewer: 1. Click the menu button and select . 2. In the panel, go down to the Applications section. ''(SO WHERE IN THE HELL IS THIS SECTION???)'' YOU CAN'T DO I never selected Mozilla to open any pdf and there's no where to opt out or change based on what all the troubleshooting tips say... All these tips must be located on a much older version of Firefox cause they ain't in my version OR they are hid under some dubious section... Pretty frustrating....when you want to use Adobe and can't cause I'm locked in under Firefox....don't know how that has happened unless it was done automatically under one of the many current upgrades that have been coming down over the last month.

Asịsa ahọpụtara

Army1 said

...when I try to save the pdf doc. it still saves it as a Firefox HTML DOC.

One possibility is that the file name has .html on the end, which is not what you want because it's not a web page. You can change a Windows setting to force it to show you the true file extensions: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/. Is Firefox adding .html when saving PDFs?

Another possibility is that the file extension is correct, but Windows' default application for PDFs is Firefox instead of Acrobat. I never used Windows 8.1, but if you go to wherever you set default applications, and you set the default for PDF back to Adobe, does the description change? If it already is Adobe, try switching around among applications and see whether Windows gets the message that it's NOT a Firefox file.

Gụọ azịza a na nghọta 👍 1

All Replies (11)

more options

You could also get the free Adobe Acrobat Reader download and install that as default pdf reader. And since there is no more info as to what pdf or pdf site your reading the pdf no one reading is going to know what is going on here.

Helpful?

more options

See Settings > General > Applications. At some point Mozilla started altering choices made by users so you may find there are other settings you want to change.

There is a preference in about:config to disable Firefox as a pdf viewer. Change as shown if you want to go that far. pdfjs.disabled > true

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Helpful?

more options

By the way, the Settings page has a tiny search box you can use to filter it. This can be handy when scrolling down doesn't bring what you are looking for into view. For example, you could type applic to pull up the Applications section, or even PDF (although that might appear in other places as well).

Helpful?

more options

jscher2000 - Support Volunteer Thanks for the info...didn't see three dots but inputted Appl in the search box at top of Settings page and it got me to where I changed the default reader to be Adobe Reader, which I already had, but when I try to save the pdf doc. it still saves it as a Firefox HTML DOC. Do I have to restart the desktop for it to take affect? I restarted Firefox, but that didn't help either. Any other idea?

Helpful?

more options

Terry, thanks for the feedback... opened the link you sent about config, but I'm lost there...don't know where to go/do on that page

Helpful?

more options

Asịsa Ahọpụtara

Army1 said

...when I try to save the pdf doc. it still saves it as a Firefox HTML DOC.

One possibility is that the file name has .html on the end, which is not what you want because it's not a web page. You can change a Windows setting to force it to show you the true file extensions: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/. Is Firefox adding .html when saving PDFs?

Another possibility is that the file extension is correct, but Windows' default application for PDFs is Firefox instead of Acrobat. I never used Windows 8.1, but if you go to wherever you set default applications, and you set the default for PDF back to Adobe, does the description change? If it already is Adobe, try switching around among applications and see whether Windows gets the message that it's NOT a Firefox file.

Helpful?

more options

jscher2000 - Support Volunteer Hey man, Praise the Lord.... the Bleeping Computer Link did the trick...! I really appreciate the help... Great and Blessed holidays to you!

Helpful?

more options

P.S. there is no HTML extension in the address line...

Helpful?

more options

No .html is correct. So were you able to change the document type explanation through Windows' Default Apps settings?

Helpful?

more options

jscher2000 The BC link stating to single click on the folder enabled me to select Adobe Reader again as my default for all pdf to be opened and that cleared my problem up and "so far" windows has maintained that default. tx again

Helpful?

more options

Great, thank you for reporting back.

Helpful?

Jụọ ajụjụ

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.