Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

KEEP ME SIGNED IN/NO NOT WORKING IN MY LIVE.COM ACCT

  • 19 replies
  • 2 have this problem
  • 35 views
  • Nzaghachi ikpeazụ nke DOLSZOWY

more options

SINCE THIS DOESN'T HAPPEN WHEN I SIGN INTO MY LIVE.COM EMAIL WHEN I USE EDGE, MICROSOFT SAYS THAT THIS IS A FIREFOX PROBLEM. MAYBE!

AFTER I ENTER MY LOGIN PASSWORD TO GET INTO MY LIVE.COM EMAIL, I AM RE-DIRECTED TO A WINDOW THAT ASKS IF I WANT TO STAY SIGNED IN (KEEP ME SIGNED IN). THE 2 CHOICES AVAILABLE ARE "NO" AND "DON'T SHOW THIS WINDOW AGAIN". NEITHER OF THESE 2 BUTTONS WORK AS I KEEP GETTING THEM EVERY TIME I LOG INTO MY EMAIL.
ONE THING I HAVE NOTED IS THAT IF I GO BACK 1 PAGE FROM THE "KMSI" PAGE, THIS OFTEN TAKES ME TO MY LIVE.COM EMAIL INBOX. THIS MAKES ME THINK THAT I AM BEING RE-DIRECTED TO THE "KMSI" PAGE! AS STATED EARLIER MS SAYS THIS IS A FIREFOX PROBLEM BECAUSE WHEN I LOG IN USING EDGE, THE BUTTONS WORK AND THE "KMSI" WINDOW DOESN'T RE-APPEAR!

THIS HAS BEEN GOING ON/OFF SINCE 11/18 AND HAVE BEEN TRYING TO GET MICROSOFT TO FIX THE PROBLEM SINCE THEN. ANY HELP IS GREATLY APPRECIATED! SINCERELY, D

All Replies (19)

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

HI FREDMcD, THANKS FOR THE RESPONSE,

I HAVE CLEARED THE CACHE, DELETED BROWSING HISTORY (ALSO UPON EXIT), CONSTANTLY DELETE COOKIES (I ALSO RUN CCLEANER AT STARTUP AND PERIODICALLY RUN AML REG AND DISK CLEANER. ALSO HAVE SETTINGS SET TO STRICT MODE WITH TRACKING PROTECTION ACTIVATED.
ALSO, I NEVER SAVE PASSWORDS, AUTO FILL DATA OR ANY OTHER PERSONAL INFO.

HAVING SAID AND DONE ALL THAT, THE PROBLEM PERSISTS! I STILL THINK IT HAS SOMETHING TO DO WITH THE FACT THAT IF I GO BACK ONE PAGE FROM THE "KEEP ME SIGNED IN PAGE", I CAN GET INTO MY EMAIL INBOX WITHOUT SELECTING EITHER OF THE CHOICES IN THE "KEEP ME SIGNED IN WINDOW". ANY HELP IS ALWAYS APPRECIATED! D

Helpful?

more options

Hello,

Not to sound rude, but Microsoft (and most other websites, for that matter) store both your login data, and the preferences (stay logged in) in your cookies. By deleting your cookies, you are effectively logging out.

I reread this and would like to note, it does not store your username and password, it stores a token that can be validated by the server and can be therefore used to stay signed in without constantly sending your username and password.

Edeziri site na Amelia

Helpful?

more options

HI ANDMAGDO, THANKS FOR THE RESPONSE,

ALSO NOT TRYING TO BE RUDE, BUT MY PROBLEM IS THAT THE "KEEP ME SIGNED IN" WINDOW OPENS EVERY SINGLE TIME AFTER I ENTER MY LOGIN PASSWORD! DEPRESSING THE "NO" BUTTON MEANING THAT I DON'T WANT TO STAY LOGGED IN AND DEPRESSING THE "DON'T SHOW THIS AGAIN" BUTTON DON'T WORK AND THE WINDOW RE-APPEARS THE NEXT TIME I LOG INTO MY EMAIL. 
 ON SECOND THOUGHT, I GUESS THE "NO" BUTTON DOES WORK AS I HAVE TO LOG IN WITH MY PASSWORD. SO THE "DON'T SHOW THIS AGAIN"  BUTTON IS KAPUT.
AND WHY IS IT THAT IF I GO BACK 1 PAGE FROM THE "KEEP ME SIGNED IN" PAGE CAN I GET INTO MY EMAIL INBOX?

ANY HELP IS ALWAYS APPRECIATED, D

Helpful?

more options

DOLSZOWY said

HI ANDMAGDO, THANKS FOR THE RESPONSE, ALSO NOT TRYING TO BE RUDE, BUT MY PROBLEM IS THAT THE "KEEP ME SIGNED IN" WINDOW OPENS EVERY SINGLE TIME AFTER I ENTER MY LOGIN PASSWORD! DEPRESSING THE "NO" BUTTON MEANING THAT I DON'T WANT TO STAY LOGGED IN AND DEPRESSING THE "DON'T SHOW THIS AGAIN" BUTTON DON'T WORK AND THE WINDOW RE-APPEARS THE NEXT TIME I LOG INTO MY EMAIL. ON SECOND THOUGHT, I GUESS THE "NO" BUTTON DOES WORK AS I HAVE TO LOG IN WITH MY PASSWORD. SO THE "DON'T SHOW THIS AGAIN" BUTTON IS KAPUT. AND WHY IS IT THAT IF I GO BACK 1 PAGE FROM THE "KEEP ME SIGNED IN" PAGE CAN I GET INTO MY EMAIL INBOX? ANY HELP IS ALWAYS APPRECIATED, D

Helpful?

more options

>AND WHY IS IT THAT Once you are signed in, you need to sign out before the site will have you log in again.

Helpful?

more options

YOU ARE NOT SEEING THE PROBLEM!

I DON'T WANT THAT STUPID " KEEP ME SIGNED IN" WINDOW APPEARING EVERY SINGLE TIME I LOGIN TO MY EMAIL! THAT IS WHY I CHECK "NO" AND "DON'T SHOW THIS MESSAGE AGAIN".

I AM NOT BEING KEPT "SIGNED IN" AND I ALWAYS LOG OFF MY ACCOUNT, SO THE "NO" BUTTON WORKS. SOOOOOO, WHEN AFTER I ENTER MY PASSWORD, RATHER THAN GOING DIRECTLY TO MY EMAIL INBOX, I AM RE-DIRECTED TO THAT STUPID "KEEP ME SIGNED IN' WINDOW!!! I KEEP CHECKING THE "DON'T SHOW THIS MESSAGE AGAIN" BUTTON SO I DON'T HAVE TO SEE THIS WINDOW AGAIN. BUT IT DOESN'T WORK! WHY WON'T THAT WINDOW GO AWAY??? AGAIN, ANY HELP IS GREATLY APPRECIATED. D

Helpful?

more options

I called for more help.

Helpful?

more options

Could you please type in normal text instead of ALL CAPS. If you have difficulty seeing the letters, use the Zoom feature to enlarge the page. Also, try not to start the line with a space or tab since that causes non-wrapping lines.

Question #1: On your Settings page, what is your cookie setting here:

If you have that box checked, you need to create exceptions for Outlook using the button to the right. Click the Manage Exceptions button and type or paste

https://live.com

and then click Allow and Save Changes.

Question #2: On your settings page, what is your History setting here:

If you are clearing history when Firefox closes, we need to review your settings to make sure you are not removing your Outlook cookies.

Helpful?

more options

hi jscher2000, thanks for the response. sorry about the caps- just easier for me. i delete cookies and site data when firefox closes. added the live.com to exceptions. restarted firefox and still got the "keep me signed in" window after entering my password. i use "custom setting for history", but i only have "clear history when firefox closes" checked. it seems that checking the 2 previous boxes- "remember browsing and downloaded history" and "remember search and form history" are unnecessary as i am clearing history when firefox closes. or am i wrong and i need to have those checked too? so i checked those also, restarted firefox and still have the "keep me signed in" window opening. i re-checked "managed exceptions again and https://live.com was gone. it seems to disappear each time i log into my live.com account. thanks for the help. it is always appreciated, d

Helpful?

more options

DOLSZOWY said

i use "custom setting for history", but i only have "clear history when firefox closes" checked. it seems that checking the 2 previous boxes- "remember browsing and downloaded history" and "remember search and form history" are unnecessary as i am clearing history when firefox closes. or am i wrong and i need to have those checked too? so i checked those also, restarted firefox and still have the "keep me signed in" window opening. i re-checked "managed exceptions again and https://live.com was gone. it seems to disappear each time i log into my live.com account.

Click the Settings button to the right of "Clear history when Firefox closes" and UN-CHECK these three boxes:

  • Cookies
  • Site Settings -- your exceptions and site-specific permissions
  • Offline website data

This feature does not currently respect exceptions (that should be fixed later this year), and actually you have it set up to erase your exceptions, so you need to adjust it.

Helpful?

more options

hi jscher2000, thanks again or the response. unchecked those 3 boxes, restarted firefox and still got the "keep me signed in" window after entering my password. restarted laptop too and still am getting "kmsi" window. also the https://live.com exception was gone again. still disappears whenever i start firefox even though i allowed it for all sessions. also wondering about being able to go back one page from the "kmsi" window to get to my email inbox. again, thanks for the help. it is always appreciated! D

Helpful?

more options

The "Keep me signed in" is not a required element of the login flow, it occurs after login, which is why you don't need to bother with that form just to use the site for the current session, only if you want a persistent cookie.

I am troubled that the exception keeps getting removed. The only setting that I know would cause that is using Clear history when Firefox closes with "Site settings" selected to be cleared. Or using automatic private browsing ("Never remember history").

Does Firefox have trouble retaining other exceptions such as popup-blocking exceptions, video autoplay exceptions, camera/microphone permissions, notification permissions, etc., or is the problem limited to cookie exceptions?

Do you have any external cleaning software that might be removing or otherwise tampering with Firefox data files?

Helpful?

more options

hi jscher2000, thanks again or the response. the only way to get past the "kmsi" window is to click no,click 'no ' and don't show this again, or by going back 1 page. i always open my live.com login page in a private window. could this be causing it? i'll try opening it later in a regular window. i have never noticed any other deviations, so i assume it is cookie related. i do use ccleaner at startup, but checked and live.com and login.live.com are "kept" cookies. and this wouldn't cause the missing exception as it only runs at start-up and if i restart firefox without restarting my laptop, the exception is missing. again your help is greatly appreciated, d

Helpful?

more options

hi jscher2000, ok, i opened my login page in a regular window (not-private) and it went directly to my email inbox, bypassing the notorious "keep me signed in" window!!! hurray! i will keep monitoring the situation and keep you apprised if this is the actual solution! i have been battling this problem with microsoft since 3/20 and was ready to move my email to yahoo, gmail or somebody else. i didn't want to do that or start using edge, etc as i have been using firefox for years. also, since it looks as if i can keep firefox, is there anyway to delete multiple bookmarks at one time? since i have been using firefox, my "other bookmarks" file runs for like 60 seconds to get to the end of it. again, thanks for the help! was really getting tired of that stupid window! D

Helpful?

more options

Okay, the regular versus private makes sense, since the cookie jar for the regular windows and the private windows are separate.

Regarding bookmarks, you can throw those into a subfolder if you don't want to pick through them right now. For example:

Open the Library window/Manage Bookmarks (Ctrl+Shift+O)

Firefox should display Other Bookmarks by default, or you can switch to it by clicking Other Bookmarks in the left column.

In the left column, right-click Other Bookmarks and click Add Folder. I think OLD would be a suitable name, but choose anything you like. Firefox will show this new empty folder on the right. Change back to viewing Other Bookmarks by clicking it in the left column.

In the right panel, if the Added column is not showing, right-click any column heading and click Added on the list. If Added is on the list but you don't see it, drag the divider on the right side of the last column to the left until the hidden column(s) come into view. You can sort bookmarks by added date by clicking the Added column. This should help in moving the oldest ones off to the OLD folder.

In the right panel, you can multi-select bookmarks using the usual methods you use in Windows File Explorer. For example, click the first bookmark in the range you want to move and then Shift+click the last.

Drag the selected bookmarks from the right side to the left column and drop them on the OLD folder. It make take 15-30 seconds for Firefox to complete the move, during which time it may appear that nothing is happening... or maybe that's just me.

Helpful?

more options

hi jscher2000, thanks for the response! it appears that for the most part, opening in a new window vs a private one works most of the time. i think one time i had to deal with the "kmsi" window. but i have only opened my mail 3 or 4 times. as far as managing cookies, the live.com, hotmail.com, etc, that i allowed are gone again. i don't know if this will effect the opening of that window or not, but can't figure out why they disappear! hopefully it won't make a difference. but just like debugging a program, some issues only arise when a certain set of parameters arise and that can drive a person nuts! thanks for the info on removing bookmarks! this will greatly simplify a tedious task. i'll keep you appraised on the "kmsi" situation and again all the help is greatly appreciated! d

Helpful?

more options

hi jscher2000, well i thought the problem was fixed. not so much. i can't figure out why my managed cookies keep disappearing. it's like the "allow" acts the same as "allow for this session"and is only good once. ccleaner has "live.com", "login.live.com" and " outlook.live.com" as cookies to keep. i don't have any other maintenance programs running at start-up. i re-added the cookie exceptions again and now both the "http" and the "https" addresses are included. when i entered "live.com" for example, both addresses opened up in the exception box! same for other 2. maybe i need both? doesn't seem logical to me, but we'll see. again, thanks for the help, d

Helpful?

more options

hi jscher2000, ready to throw in the towel. back to square 1. no matter what i do, now i keep getting the "keep me signed in" window! any help is always appreciated. thanks, d

Helpful?

Jụọ ajụjụ

Ị ga-abanyerịrị n'akaụntụ gị iji zaghachi mbisa. Biko bido otu ajụjụ ọhụrụ, ọ bụrụ na ị nwebeghị akaụntụ.