Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lost my much needed desktop Firefox

  • 5 replies
  • 1 nwere nsogbu anwere nsogbu a
  • 17 views
  • Nzaghachi ikpeazụ nke Rando

more options

I keep getting the same error even after deleting everything including profiles and reinstalling a fresh copy of Firefox “ Firefox is already running please close processes “ I go to tsk manager and end the processes but it still won’t start up. It’s the only browser I use and I’m in a real dilemma eith it now

All Replies (5)

more options

I assume you've tried restarting your computer to see if that will restore it, and have you followed all the steps in this article? https://support.mozilla.org/en-US/kb/firefox-already-running-not-responding?

Let me know!

more options

Thank you for your help , I’m really bummed I can’t get this running. For years I’ve used Firefox with no major problems. Luckily I can manage a few things with my mobile version. I still can access my favorites and pay my bills. Anyway yes I’ve made sure the “read only” box is checked and I’ve even deleted absolutely everything Mozilla or Firefox all throughout my PC and reinstalled a brand new copy and I’m getting the same thing. Oddly, ending the process in task manager sometimes works and other times it will not go away when I click “end process” This is frustrating me to no end because I can’t understand why after deleting everything I keep getting the same errors Any help is enormously appreciated thank you

more options

Try to remove the parent.lock (Windows) or .parentlock (Linux, Mac) file in the profile folder.

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

"AppData" (XP: Application Data; Mac: ~/Library; Linux: ~/.mozilla) is a hidden folder.


You can create a new profile if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Can anybody provide any further assistance with this ?

more options

Removing the patent lock ( from 3 different places ) seems to have worked ! Thank you so much for the suggestion !!!