Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't play youtube videos in Quantum

  • 9
  • 1 nwere nsogbu anwere nsogbu a
  • 20 views
  • Nzaghachi ikpeazụ nke 14woody7yar

more options

On the Firefox Quantum version, I can't play Youtube videos.

Whenever I try to play a video, it just sits there and loads.

These are the plugins that I have on this browser (and no, I can't seem to remove them): 1) Shockwave Flash 28.0, 2) Open H264 Video Codec, and 3) Widevine Content Decryption Module

When I disable the addons on the browser, the video plays.

But if I both enable the browser and disable all of the plugins, the video doesn't play.

And if I both enable the browser and activate the plugins, then I get the message of 'if playback doesn't begin shortly, try restarting your device'.

And no, restarting the computer doesn't help anything either.

What exactly is going on with this?

Lastly, thanks in advance for your help.

                                                                                                                                                                                                                    Olga
On the Firefox Quantum version, I can't play Youtube videos. Whenever I try to play a video, it just sits there and loads. These are the plugins that I have on this browser (and no, I can't seem to remove them): 1) Shockwave Flash 28.0, 2) Open H264 Video Codec, and 3) Widevine Content Decryption Module When I disable the addons on the browser, the video plays. But if I both enable the browser and disable all of the plugins, the video doesn't play. And if I both enable the browser and activate the plugins, then I get the message of 'if playback doesn't begin shortly, try restarting your device'. And no, restarting the computer doesn't help anything either. What exactly is going on with this? Lastly, thanks in advance for your help. Olga

Asịsa ahọpụtara

You are most welcome.

Gụọ azịza a na nghọta 👍 0

All Replies (9)

more options

Sounds like addon problems is happening.

more options

I have both a Mozilla theme and Unlock as add-ons.

more options

I did remove the addons that I had on here.

That didn't fix the problem.

So does anybody else have any suggestions about this?

Thanks, in advance.

more options

What A/V and Firewall do you have installed.

more options

Several of us have used this fix to good ends. Good Luck

'I found this solution in another feed. It seems to have solved my problem with the streaming video issue.


Chosen solution

Another thing to try : Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

 Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
 Select the Advanced panel and the General tab.
 Uncheck Use hardware acceleration when available.
 Close Firefox completely and then restart Firefox to see if the problem persists. 

In Firefox 55 and above:

 Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
 Select the General panel.
 Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
 Fx55Performance-disableHWA
 Uncheck Use hardware acceleration when available.
 Close Firefox completely and then restart Firefox to see if the problem persists. 

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

 Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems 
 Upgrade your graphics drivers to use hardware acceleration and Web
more options

WestEnd, Nortion is installed on the computer (for both the AV and firewall).

more options

WestEnd, I meant to say Norton.

Sorry about that.

more options

14woody7yar, both disabling the hardware acceleration and unchecking the recommended performance settings both seemed to have worked.

So thank you for your help, as it's most appreciated.

more options

Asịsa Ahọpụtara

You are most welcome.