Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Download blocked as unsafe by SmartScreen Filter in Windows10

  • 5 replies
  • 21 have this problem
  • 9976 views
  • Nzaghachi ikpeazụ nke John99

more options

I upgraded from Windows 7 to windows 10. Now when I try to download Firefox from Windows Edge, I get the message at the bottom of the screen; "Firefox Setup Stub 44.0.1.exe is unsafe to download and was blocked by SmartScreen Filter." Can't download Firefox in windows 10.

Asịsa ahọpụtara

I found an article about turning off Smartscreen in IE & Windows 7

But on a quick look I did not see any official MS article relating to Edge and Windows 10. See this third party article

Obviously it would seem wise to only temporarily disable Smartscreen, turn it back on after you install the Firefox upgrade.

I would hope MS will quickly get feedback indicating the stub installer is official an safe software.

Gụọ azịza a na nghọta 👍 4

All Replies (5)

more options

OK I see that as an issue too.

I am able to update an existing Firefox on Windows 10. I am also able to download the stub installer from getfirefox.com by using Google Chrome.

I have not tried Internet Explorer yet, or using the full installers from (I presume they are still full installers ) https://www.mozilla.org/firefox/all/

I am not a Windows Expert, I rarely use it these days. I will try to see if there are other posts or solutions for this.

more options

Asịsa Ahọpụtara

I found an article about turning off Smartscreen in IE & Windows 7

But on a quick look I did not see any official MS article relating to Edge and Windows 10. See this third party article

Obviously it would seem wise to only temporarily disable Smartscreen, turn it back on after you install the Firefox upgrade.

I would hope MS will quickly get feedback indicating the stub installer is official an safe software.

more options

The settings in Edge are changed from:

menu {thee dots icon top right) -> Settings ->  View Advanced Settings 
-> ... Smartscreen Filter ( On/Off) 

The red warning maybe clicked and offers an option to download the otherwise blocked file.

Edeziri site na John99

more options

John99 said

I found an article about turning off Smartscreen in IE & Windows 7 But on a quick look I did not see any official MS article relating to Edge and Windows 10. See this third party article Obviously it would seem wise to only temporarily disable Smartscreen, turn it back on after you install the Firefox upgrade. I would hope MS will quickly get feedback indicating the stub installer is official an safe software.

Thanks John. It helped to find out how to turn off SmartScreen temporarily. However, I installed Chrome and then downloaded Firefox from it; no problem there. Anyhow thanks for your reply with very usefull info. Cheers.

more options

Glad its fixed, thanks for posting back.

There were pretty easy workarounds, but I am not sure why the problem occurred in the first place.

It is probably also worth noting Firefox 44.0.2 is now out.