Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

google maps and Mozilla support crashes firefox

  • 12
  • 6
  • 31 views
  • Nzaghachi ikpeazụ nke FredMcD

more options

I originally had an issue of Google Maps crashing my Firefox 40.0.3 every time I load the page. I tried following the troubleshooting here: https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes

and it works in Safe Mode, but: 1. I'm on default theme already 2. I turned off hardware accelerator 3. I disabled all my extensions

and it STILL crashes. So based on this article, I can't figure out what else I can disable that would cause the crash.

Not sure if this information helps, but when I tried to load the mozilla support page titled "Ask your question to our community of users", it crashes firefox every time unless I'm in Safe Mode (which I am right now to post this).

I originally had an issue of Google Maps crashing my Firefox 40.0.3 every time I load the page. I tried following the troubleshooting here: https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems?redirectlocale=en-US&redirectslug=Troubleshooting+extensions+and+themes and it works in Safe Mode, but: 1. I'm on default theme already 2. I turned off hardware accelerator 3. I disabled all my extensions and it STILL crashes. So based on this article, I can't figure out what else I can disable that would cause the crash. Not sure if this information helps, but when I tried to load the mozilla support page titled "Ask your question to our community of users", it crashes firefox every time unless I'm in Safe Mode (which I am right now to post this).

All Replies (12)

more options

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

aboutcrashesFx29
more options

Hi, they were all submitted. Here are the most recent 10:

bp-355c3909-7d75-4295-8b2f-a38972150908 9/7/2015 6:38 PM bp-cc6909bb-d86b-446a-bef5-74c052150908 9/7/2015 6:38 PM bp-7393d948-f7c7-49c6-91b0-bbe302150908 9/7/2015 6:35 PM bp-1fe87e0f-8ace-4d02-8875-c337e2150908 9/7/2015 6:32 PM bp-d1b0ac7f-6979-42cb-bb98-14a4a2150908 9/7/2015 6:30 PM bp-52a48c3c-09cc-4b18-b5c6-892f52150908 9/7/2015 6:30 PM bp-a1b07ca6-9061-4fa1-b6dd-7c1282150908 9/7/2015 6:22 PM bp-32a49815-99e9-4e1e-8322-72b132150908 9/7/2015 6:22 PM bp-e4993455-69e1-4e40-92bf-7e62a2150908 9/7/2015 6:17 PM bp-2cce2649-79e0-4037-b907-99a7d2150908 9/7/2015 6:11 PM

more options

The crash report did not flag any programs,

But all show very high memory usage, more then 75 %


Total Virtual Memory 4294836224

Available Virtual Memory 3625893888

System Memory Use Percentage 62

Available Page File 3782270976

Available Physical Memory 1489379328


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


Firefox uses too much memory (RAM) - How to fix This article describes how to make Firefox use less memory to make it run faster and prevent crashes.

https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster

https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding

more options

Yeah, my memory usage on the laptop has always been high (above 80%), though this problem only started recently (probably after version 36 or so?). It works perfectly in safe mode, so is that due to the memory?

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "3-bar" menu button > Exit (Power button) (Windows: File > Exit; Mac: Firefox > Quit Firefox; Linux: File > Quit)

more options

Thanks for the reply, but I followed the "safe mode" instructions to the letter and as I posted in the original post:

1. I'm on default theme already 2. I turned off hardware accelerator 3. I disabled all my extensions

Yet it still crashes. the only time it doesn't crash is if I'm in Safe Mode. Is there anything else I can switch off?

more options

An updated. I freed up my memory down to 50% (Windows Update was hogging the memory) and Google Maps still crashed with 1) hardware accel turned off, 2) default themes, and 3) all extensions disabled.

Most recent 2 submitted crash report. bp-27baee21-b49a-43cd-bdbf-118032150909 9/9/2015 12:05 AM bp-26dac0a3-906d-4534-a378-f34252150909 9/9/2015 12:05 AM

I'm out of things to try... =\

more options

System Memory Use Percentage 40

Much better.

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is detective.

more options

Hi, thank you for the tip. I only have 2 Extensions and both are disabled: 1. AVG SafeGuard Toolbar 2. Logitech SetPoint

Firefox still crashes when I try to open Google Maps with both of these disabled, but it doesn't crash if I go into safe mode.

more options

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

After, restart Firefox. Are there any problems?

more options

Yes, Hardware Acceleration is turned off and Google Maps still crashes Firefox. =(

more options

Please post the new crash reports.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia