Támogatás keresése

Kerülje el a támogatási csalásokat. Sosem kérjük arra, hogy hívjon fel egy telefonszámot vagy osszon meg személyes információkat. Jelentse a gyanús tevékenységeket a „Visszaélés bejelentése” lehetőséggel.

Learn More

A témacsoportot lezárták és archiválták. Tegyen fel új kérdést, ha segítségre van szüksége.

AutoConfig.js stopped running after update to version 69

  • 3 válasz
  • 1 embernek van ilyen problémája
  • 110 megtekintés
  • Utolsó üzenet ettől: cor-el

more options

Hi. I've been using Autoconfig for a while and it's been working fine. However, after update to version 69. All of my preferences are reset to default. I tried to re-install but it still doesn't work. I don't know whether this is new policy from firefox or there are some bugs with new version.

Here is what's my autoconfig file and firefox.cfg look like

autoconfig.js

pref("general.config.filename", "firefox.cfg"); pref("general.config.obscure_value", 0);

firefox.cfg

// IMPORTANT: Start your code on the 2nd line pref("app.update.auto.migrated"; false); pref("media.autoplay.default", 0); pref("media.autoplay.allow-muted", false); pref("browser.shell.checkDefaultBrowser", false); pref("browser.sessionstore.resume_from_crash", false); pref("media.peerconnection.ice.proxy_only", true); pref("app.normandy.enabled", false); pref("browser.tabs.warnOnClose", false); pref("browser.newtabpage.activity-stream.feeds.snippets"; false);

Hi. I've been using Autoconfig for a while and it's been working fine. However, after update to version 69. All of my preferences are reset to default. I tried to re-install but it still doesn't work. I don't know whether this is new policy from firefox or there are some bugs with new version. Here is what's my autoconfig file and firefox.cfg look like autoconfig.js pref("general.config.filename", "firefox.cfg"); pref("general.config.obscure_value", 0); firefox.cfg // IMPORTANT: Start your code on the 2nd line pref("app.update.auto.migrated"; false); pref("media.autoplay.default", 0); pref("media.autoplay.allow-muted", false); pref("browser.shell.checkDefaultBrowser", false); pref("browser.sessionstore.resume_from_crash", false); pref("media.peerconnection.ice.proxy_only", true); pref("app.normandy.enabled", false); pref("browser.tabs.warnOnClose", false); pref("browser.newtabpage.activity-stream.feeds.snippets"; false);

Módosította: REDOtter,

Kiválasztott megoldás

I see two lines where you used "; false" instead of ", false"

Any error in autoconfig.cfg will throw an exception and about the processing of the file. You can check the Browser Console for error messages.

  • "3-bar" menu button or Tools -> Web Developer
Válasz olvasása eredeti szövegkörnyezetben 👍 1

Összes válasz (3)

more options

Kiválasztott megoldás

I see two lines where you used "; false" instead of ", false"

Any error in autoconfig.cfg will throw an exception and about the processing of the file. You can check the Browser Console for error messages.

  • "3-bar" menu button or Tools -> Web Developer
more options

cor-el said

I see two lines where you used "; false" instead of ", false" Any error in autoconfig.cfg will throw an exception and about the processing of the file. You can check the Browser Console for error messages.
  • "3-bar" menu button or Tools -> Web Developer

Thanks so much. I didn't see that mistake.

more options

You're welcome.

I think that in current Firefox releases the Browser Console would display error messages in case of errors.