X
Érintse meg, ha az oldal mobil verziójára kíván váltani.

Támogatói fórum

Hogyan lehet az animációkat tiltani a firefox-ban?

Beküldve

Sziasztok!

Az alábbi probléma megoldásában szeretném kérni a segítségetek. Vannak weboldalak, amik tele vannak mindenféle villogó, mozgó tartalommal. Ezeket szeretném tiltani, mert alaplapi videokártya esetén nagyon belassítják a gépet.

Az animált GIF problémát már megoldottam az "image.animation_mode;none" kulccsal. Jelenleg a java scriptben lévő class-okkal van bajom ("image" animációk) és most, újdonságként, a könyvjelzők között megjelenő képek animációval.

A java-s class-okat jelenleg reklámblokkolóval tiltom, de ez macerás, mert csak egyesével lehet a komponenseket tiltani és mindenképp ki kell várni az oldal betöltését, ami sok idő. Ráadásul ezek a háttérben is futnak terhelve a CPU-t. A helyi menüben - a jobb egérgombra megjelenő - az "Elem vizsgálata" részben leállíthatóak az animációk, de ez mire - a folyton mozgó tartalom miatt - betöltődik, az még több idő és csak ideiglenes megoldás.

Nem tudom, hogy írhatok-e ide konkrét web címet példának, ezért inkább körbeírom a jelenséget. Pl. #1: Amíg nem töltődik be egy oldal vagy csak egy egyszerű "browser check" oldal esetén, mindig valamilyen kép pattog, forog jelezvén, hogy az oldal töltődik vagy "dolgozik".

Az elem vizsgálóban ez valahogy így néz ki. (egy fogaskerék forog)

Az animációs ablakban meg ezek vannak: (pattogó logó és két fogaskerék az oldalon)

img.flat.logo - floating
img.rotate - floating
img.rotate - floating

A blokkolt tartalom ublock origin-ban: (pattogó logó és két fogaskerék az oldalon)

##.logo.float
##.first.gear > .rotate
##.second.gear > .rotate

A legtöbb loader és preloader tiltható az alábbi sorokkal, de több oldal van, ami egyedi class-t használ.

##.loader
###loader
##.preloader
###preloader

Továbbá, ha ugyanez az oldal <iframe>-be töltődik haszontalan minden ublok szabály, mert a fő ablak beállításai lesznek az érvényesek, ahol nincs tiltva semmi.

Pl. #2: A könyvjelzők közé felvettem egy oldalt, aminek egy mozgó grafikon az ikonja. Elvileg a GIF animáció tiltott, de ez mozog és villog, ami nyitott könyvjelzők mellett nagyon zavaró.

Eddig ezeket a kulcsokat állítottam:

image.animation_mode;none //GIF animációk tiltása
media.autoplay.enabled;false //Videók lejátszásának tiltása kikapcsolva
browser.fullscreen.animate;false //Teljes képernyőre váltás animálásának kikapcsolása (F11)
browser.download.animateNotifications;false //Letöltési ikon animálásának tiltása
browser.tabs.animate;false //Fülek animálásának tiltása

Ezeket próbáltam, de hatástalan és nem is tudom mit kellene tiltania:

dom.animations-api.element-animate.enabled;true
layout.animated-image-layers.enabled;false

Használt böngésző és kiegészítők:

FireFox ESR 52.9.0 //Tudom régi, de ez van.
uBlock origin //Szemétszűrő
NoScript //Ezekre az animációkra hatástalan, a default értékekkel.
GreaseMonkey //Tesztelés alatt, de ez is csak egyesével tud tiltani és nem értek annyira a java kódhoz.

Amennyiben nem tudtok segíteni, az is elegendő lenne, ha tudnátok ajánlani oldal(aka)t, ahol fellelhető a FireFox config kulcsairól valami részletes dokumentáció, hogy mi mire való vagy mit állít be.

Segítségeteket előre is köszönöm.

Sziasztok! Az alábbi probléma megoldásában szeretném kérni a segítségetek. Vannak weboldalak, amik tele vannak mindenféle villogó, mozgó tartalommal. Ezeket szeretném tiltani, mert alaplapi videokártya esetén nagyon belassítják a gépet. Az animált GIF problémát már megoldottam az "image.animation_mode;none" kulccsal. Jelenleg a java scriptben lévő class-okkal van bajom ("image" animációk) és most, újdonságként, a könyvjelzők között megjelenő képek animációval. A java-s class-okat jelenleg reklámblokkolóval tiltom, de ez macerás, mert csak egyesével lehet a komponenseket tiltani és mindenképp ki kell várni az oldal betöltését, ami sok idő. Ráadásul ezek a háttérben is futnak terhelve a CPU-t. A helyi menüben - a jobb egérgombra megjelenő - az "Elem vizsgálata" részben leállíthatóak az animációk, de ez mire - a folyton mozgó tartalom miatt - betöltődik, az még több idő és csak ideiglenes megoldás. Nem tudom, hogy írhatok-e ide konkrét web címet példának, ezért inkább körbeírom a jelenséget. Pl. #1: Amíg nem töltődik be egy oldal vagy csak egy egyszerű "browser check" oldal esetén, mindig valamilyen kép pattog, forog jelezvén, hogy az oldal töltődik vagy "dolgozik". Az elem vizsgálóban ez valahogy így néz ki. (egy fogaskerék forog) <div class="gear"> <img class="rotate" src="data:image/png..." alt=""> </div> Az animációs ablakban meg ezek vannak: (pattogó logó és két fogaskerék az oldalon) img.flat.logo - floating img.rotate - floating img.rotate - floating A blokkolt tartalom ublock origin-ban: (pattogó logó és két fogaskerék az oldalon) ##.logo.float ##.first.gear > .rotate ##.second.gear > .rotate A legtöbb loader és preloader tiltható az alábbi sorokkal, de több oldal van, ami egyedi class-t használ. ##.loader ###loader ##.preloader ###preloader Továbbá, ha ugyanez az oldal <iframe>-be töltődik haszontalan minden ublok szabály, mert a fő ablak beállításai lesznek az érvényesek, ahol nincs tiltva semmi. Pl. #2: A könyvjelzők közé felvettem egy oldalt, aminek egy mozgó grafikon az ikonja. Elvileg a GIF animáció tiltott, de ez mozog és villog, ami nyitott könyvjelzők mellett nagyon zavaró. Eddig ezeket a kulcsokat állítottam: image.animation_mode;none //GIF animációk tiltása media.autoplay.enabled;false //Videók lejátszásának tiltása kikapcsolva browser.fullscreen.animate;false //Teljes képernyőre váltás animálásának kikapcsolása (F11) browser.download.animateNotifications;false //Letöltési ikon animálásának tiltása browser.tabs.animate;false //Fülek animálásának tiltása Ezeket próbáltam, de hatástalan és nem is tudom mit kellene tiltania: dom.animations-api.element-animate.enabled;true layout.animated-image-layers.enabled;false Használt böngésző és kiegészítők: FireFox ESR 52.9.0 //Tudom régi, de ez van. uBlock origin //Szemétszűrő NoScript //Ezekre az animációkra hatástalan, a default értékekkel. GreaseMonkey //Tesztelés alatt, de ez is csak egyesével tud tiltani és nem értek annyira a java kódhoz. Amennyiben nem tudtok segíteni, az is elegendő lenne, ha tudnátok ajánlani oldal(aka)t, ahol fellelhető a FireFox config kulcsairól valami részletes dokumentáció, hogy mi mire való vagy mit állít be. Segítségeteket előre is köszönöm.

Módosította: Meskó Balázs,

Idézet

További rendszeradatok

Telepített bővítmények

  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.9.199
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Alkalmazás

  • Felhasználói ügynök: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

További információk

Meskó Balázs
  • Moderator
121 megoldás 595 válasz

Szia!

Először is: JavaScript, semmi köze a Javához.

Alapvetően nem tudod csak úgy letiltani az animációkat. A Greasemonkey segítségével szinte mindent tudsz blokkolni a lapokon, de ezt oldalanként külön kell megcsinálnod.

A faviconok esetében viszont rosszabb a helyzet, ezeknél jelenleg nem lehet egyáltalán letiltani az animációkat. Szerencsére az UBlock Originnel letilthatóak a faviconok, egy egyéni szűrőt kell felvenni a megfelelő URL-lel, pl.:

||http://www.example.com/favicon.ico
Szia! Először is: JavaScript, semmi köze a Javához. Alapvetően nem tudod csak úgy letiltani az animációkat. A Greasemonkey segítségével szinte mindent tudsz blokkolni a lapokon, de ezt oldalanként külön kell megcsinálnod. A faviconok esetében viszont rosszabb a helyzet, ezeknél jelenleg nem lehet egyáltalán letiltani az animációkat. Szerencsére az UBlock Originnel letilthatóak a faviconok, egy egyéni szűrőt kell felvenni a megfelelő URL-lel, pl.: ||http://www.example.com/favicon.ico
Hasznos volt ez?
Idézet

Kérdés tulajdonosa

Szervusz Balázs!

Köszönöm a válaszodat. 1, Sajnos a faviconok uBlock-kal való tiltása haszontalan. Legalább is nekem nem működött, mert az icon animációja ugyanúgy elindult a lap betöltésekor. Mind a „TAB”-on, mind a könyvjelzők között. Egy esetben volt csak eredményes, amikor konkrétan a „favicon.ico”-t nyitottam meg. Fura, mert betöltötte a fájlt, de az animáció már elmaradt. Feltételezem a GIF tiltása miatt. Továbbá egyből frissítette a nyitott „TAB”-on is a favicon-t, ami eddig mozgott, most eltűnt. A könyvjelzőre viszont teljesen hatástalan volt. Mivel a favicon nekem új dolog volt, így rákerestem és itt a Mozilla Support angol oldalán is találtam végleges megoldásokat.

1.1, A favicon-ok használatának tiltása az „about: config”-ban: Ezt a két bejegyzés kell „false” értékre állítani és megszűnik minden favicon feldolgozása. Mind a „TAB”-on, mind a könyvjelzőkben. A „TAB”-okon nem jelenik meg, a könyvjelzőknél meg a default, szürke földgömb lesz mindenhol. Ha nem működne, akkor gyorsító tárak ürítése és FF újraindítása. browser.chrome.favicons browser.chrome.site_icons

1.2, Ezt nem próbáltam ki! Elvileg létre kell hozni egy „userChrome.css” nevű fájlt, a profil mappában egy megadott tartalommal. Ezt nem másolnám ide, csak belinkelem. Bővebben és angol nyelven itt: https://support.mozilla.org/en-US/questions/934198#answer-358597

1.3, Egy másik fórumon ennél is egyszerűbb megoldást javasoltak. Ha ritkán használom az érintett könyvjelzőt, rakjam a könyvjelzők lista végére és nem fog zavarni a villogása. :) Feltételezve, hogy több bejegyzésem van, mint az ablak magassága.

2, A másik, animációs problémára sajnos semmilyen megoldást nem találtam. Se plugin, se leírás. Átnéztem a config-ot is, de nincs benne olyan rész, ami megakadályozná az animációk elindulását. A GreaseMonkey-al való tiltás macerásabb, mint a blokkolóval, mert minden oldalhoz külön „script”-et kellene létrehozni, míg blokkoló esetén 1 listában van minden szűrési szabály és csak pár klikk. Általánosítani pedig nem lehet mert, ahány oldal annyit elnevezése van az „class”-oknak. Így sajnos, egy betöltést mindenképp meg kell várni és csak utána élhet tiltás.

Kérdés(ek): Esetleg tudnál abban segíteni, hogy működik ezeknek a javascipt-es animációknak a futtatása? Az elem vizsgálóban mindegyik animációnak van ideje. Nem lehetne általánosan blokkolni az időzítőt? Sajnos az oldalak forráskódjában nem láttam ilyesmit, viszont így nem tudom, mi futtathatja az animációt?

3, Ha netán érdekelne még valakit az about:config bejegyzései és funkciójuk leírásai, az alábbi tudásbázis oldalon olvashat róluk. Sajnos 2017-es, így számos bejegyzés már nem valós, de még használható. http://kb.mozillazine.org/About:config_entries

Szervusz Balázs! Köszönöm a válaszodat. 1, Sajnos a faviconok uBlock-kal való tiltása haszontalan. Legalább is nekem nem működött, mert az icon animációja ugyanúgy elindult a lap betöltésekor. Mind a „TAB”-on, mind a könyvjelzők között. Egy esetben volt csak eredményes, amikor konkrétan a „favicon.ico”-t nyitottam meg. Fura, mert betöltötte a fájlt, de az animáció már elmaradt. Feltételezem a GIF tiltása miatt. Továbbá egyből frissítette a nyitott „TAB”-on is a favicon-t, ami eddig mozgott, most eltűnt. A könyvjelzőre viszont teljesen hatástalan volt. Mivel a favicon nekem új dolog volt, így rákerestem és itt a Mozilla Support angol oldalán is találtam végleges megoldásokat. 1.1, A favicon-ok használatának tiltása az „about: config”-ban: Ezt a két bejegyzés kell „false” értékre állítani és megszűnik minden favicon feldolgozása. Mind a „TAB”-on, mind a könyvjelzőkben. A „TAB”-okon nem jelenik meg, a könyvjelzőknél meg a default, szürke földgömb lesz mindenhol. Ha nem működne, akkor gyorsító tárak ürítése és FF újraindítása. browser.chrome.favicons browser.chrome.site_icons 1.2, Ezt nem próbáltam ki! Elvileg létre kell hozni egy „userChrome.css” nevű fájlt, a profil mappában egy megadott tartalommal. Ezt nem másolnám ide, csak belinkelem. Bővebben és angol nyelven itt: https://support.mozilla.org/en-US/questions/934198#answer-358597 1.3, Egy másik fórumon ennél is egyszerűbb megoldást javasoltak. Ha ritkán használom az érintett könyvjelzőt, rakjam a könyvjelzők lista végére és nem fog zavarni a villogása. :) Feltételezve, hogy több bejegyzésem van, mint az ablak magassága. 2, A másik, animációs problémára sajnos semmilyen megoldást nem találtam. Se plugin, se leírás. Átnéztem a config-ot is, de nincs benne olyan rész, ami megakadályozná az animációk elindulását. A GreaseMonkey-al való tiltás macerásabb, mint a blokkolóval, mert minden oldalhoz külön „script”-et kellene létrehozni, míg blokkoló esetén 1 listában van minden szűrési szabály és csak pár klikk. Általánosítani pedig nem lehet mert, ahány oldal annyit elnevezése van az „class”-oknak. Így sajnos, egy betöltést mindenképp meg kell várni és csak utána élhet tiltás. Kérdés(ek): Esetleg tudnál abban segíteni, hogy működik ezeknek a javascipt-es animációknak a futtatása? Az elem vizsgálóban mindegyik animációnak van ideje. Nem lehetne általánosan blokkolni az időzítőt? Sajnos az oldalak forráskódjában nem láttam ilyesmit, viszont így nem tudom, mi futtathatja az animációt? 3, Ha netán érdekelne még valakit az about:config bejegyzései és funkciójuk leírásai, az alábbi tudásbázis oldalon olvashat róluk. Sajnos 2017-es, így számos bejegyzés már nem valós, de még használható. http://kb.mozillazine.org/About:config_entries
Hasznos volt ez?
Idézet
Kérdezzen

Be kell jelentkeznie fiókjába a válaszadáshoz. Kezdjen új kérdést, ha még nincs fiókja.