X
Érintse meg, ha az oldal mobil verziójára kíván váltani.

Támogatói fórum

A témacsoportot lezárták és archiválták. Tegyen fel új kérdést, ha segítségre van szüksége.

Disable adaptive mouse wheel scrolling

Beküldve

The one and only thing that prevents me from using Firefox is this annoying "feature" that apparently can not be disabled. What I mean by it? It's pretty simple: when you scroll with a wheel slow - web page moves slowly, when you scroll faster - you've probably already guessed what happens. But I want every step to be completely consistent with its speed. There was an addon called SmoothWheel (http://smoothwheel.mozdev.org/) which implements an option to disable this behavior (https://i.imgur.com/22rKUaM.png) but it is not compatible with never Firefox versions. Hence, I am forced to stay on a 51.0.1 version, but I WANT to use all the new features like multiprocess. I don't know ANY other browser that have this kind of behavior turned on by default, I've seen this only in Firefox. Maybe I am missing something and there is a way to disable this annoying feature through about:config?

The one and only thing that prevents me from using Firefox is this annoying "feature" that apparently can not be disabled. What I mean by it? It's pretty simple: when you scroll with a wheel slow - web page moves slowly, when you scroll faster - you've probably already guessed what happens. But I want every step to be completely consistent with its speed. There was an addon called SmoothWheel (http://smoothwheel.mozdev.org/) which implements an option to disable this behavior (https://i.imgur.com/22rKUaM.png) but it is not compatible with never Firefox versions. Hence, I am forced to stay on a 51.0.1 version, but I WANT to use all the new features like multiprocess. I don't know ANY other browser that have this kind of behavior turned on by default, I've seen this only in Firefox. Maybe I am missing something and there is a way to disable this annoying feature through about:config?

További rendszeradatok

Telepített bővítmények

  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.151.2 for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 28.0 r0
  • VLC media player Web Plugin

Alkalmazás

  • Firefox 51.0.1
  • Felhasználói ügynök: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
  • Támogatás URL: https://support.mozilla.org/1/firefox/51.0.1/WINNT/en-US/

Kiegészítők

  • Add to Search Bar 2.9 (add-to-searchbox@maltekraus.de)
  • Add-on Compatibility Reporter 2.2.4 (compatibility@addons.mozilla.org)
  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Classic Theme Restorer 1.7.3.4 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Clippings 5.1.2 ({91aa5abe-9de4-4347-b7b5-322c38dd9271})
  • DownThemAll! 3.0.8 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Emoji Cheatsheet for GitHub, Basecamp etc. 2.0.1 (jid1-Xo5SuA6qc1DFpw@jetpack)
  • Enhanced Steam 7.3 (jid1-YdiFiTEkQgInxA@jetpack)
  • ePN CashBack Plugin 0.8.13 (jid1-XAZYVkS6OPAR5Q@jetpack)
  • FB2 Reader 0.28 (fb2reader@clear.com.ua)
  • Greasemonkey 3.11 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • gtranslate 0.14.0 ({aff87fa2-a58e-4edd-b852-0a20203c1e17})
  • HTTPS Everywhere 5.2.21 (https-everywhere@eff.org)
  • Imagus 0.9.8.60 ({00000f2a-7cde-4f20-83ed-434fcb420d71})
  • Multi-process staged rollout 1.7 (e10srollout@mozilla.org)
  • OpenDownload² 4.1.2 ({210249CE-F888-11DD-B868-4CB456D89593})
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Private Tab 0.2.2 (privateTab@infocatcher)
  • Rehost Image 1.5.20 (rehostimage@engy.us)
  • Search By Image (by Google) 1.1.4 ({ce7e73df-6a44-4028-8079-5927a588c948})
  • Shortly URL Shortner 2.1 (shortly@aloshbennett.in)
  • SmoothWheel (AMO) 0.45.8.20130519.3.1-signed.1-signed ({5F590AA2-1221-4113-A6F4-A4BB62414FAC})
  • Tab Mix Plus 0.5.0.4 ({dc572301-7619-498c-a57d-39143191b318})
  • uBlock Origin 1.13.8 (uBlock0@raymondhill.net)
  • VkOpt 3.0.4.170822 (vkopt_moz@vkopt.net.ru)
  • Web Compat 1.0 (webcompat@mozilla.org)

JavaScript

  • incrementalGCEnabled: True

Kép

  • adapterDescription: NVIDIA GeForce GTX 670
  • adapterDescription2:
  • adapterDeviceID: 0x1189
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_f936d37e592b25aa\nvldumd.dll
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: DISPLAY1 [ Gamma: 2,2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] DISPLAY2 [ Gamma: 2,2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ]
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 10.0.16299.15
  • driverDate: 10-27-2017
  • driverDate2:
  • driverVersion: 23.21.13.8813
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled via gfx.direct2d.disabled', u'type': u'user'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: No; D3D11 blacklisted with DLL atidxx32.dll (8.17.10.625); D3D9 blacklisted with DLL atiumd64.dll (9.14.10.1128)
  • webgl2Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Módosított tulajdonságok

Egyéb

  • Felhasználói JS: Nem
  • Akadálymentesítés: Nem
Shadow110 1072 megoldás 14836 válasz

You will have to look : Copy/paste (will know why say copy paste) into the search box on this page : scrollwheel and other words in another search.

Turn off : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Please let us know if this solved your issue or if need further assistance.

You will have to look : Copy/paste (will know why say copy paste) into the search box on this page : scrollwheel and other words in another search. *https://addons.mozilla.org/en-US/firefox/addon/theme-font-size-changer/ Turn off : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. Please let us know if this solved your issue or if need further assistance.
cor-el
  • Top 10 Contributor
  • Moderator
17774 megoldás 160764 válasz

You can look at the mousewheel.acceleration prefs on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can look at the mousewheel.acceleration prefs on the <b>about:config</b> page. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
cor-el
  • Top 10 Contributor
  • Moderator
17774 megoldás 160764 válasz

The System Details list shows you run an older Firefox 51.0.1 version that is no longer supported with security updates.

You can use the Firefox 52 ESR version if you cannot or do not want to use the current release. That way you will still receive security updates.

Firefox 52.5.3 ESR:

The System Details list shows you run an older Firefox 51.0.1 version that is no longer supported with security updates. You can use the Firefox 52 ESR version if you cannot or do not want to use the current release. That way you will still receive security updates. Firefox 52.5.3 ESR: *https://www.mozilla.org/en-US/firefox/organizations/all/ *https://www.mozilla.org/en-US/firefox/52.5.3/releasenotes/ *https://www.mozilla.org/en-US/firefox/52.5.3/system-requirements/

Kérdés tulajdonosa

I have tried various settings in about:config, it didn't help. You can only change acceleration, but not turn it off completely. And I don't see how Theme font changer or turning off Accessibility services are relevant to the issue.

I have tried various settings in about:config, it didn't help. You can only change acceleration, but not turn it off completely. And I don't see how Theme font changer or turning off Accessibility services are relevant to the issue.

Módosította: hypnotoad,

WestEnd 60 megoldás 5387 válasz

Those scrolling functions come set from the Mouse Driver that the Browser then uses. So you need to first check your mouse Drivers are current and configured correctly. I know I have Logitech Mouse driver/Keyboard and in there it has scrolling feature also my mouse has a lock button so if you press to release the wheel will scroll freely without stopping til end of page but if locked will only scroll so far. Otherwise your mouse could also be defective causing to scroll farther then it should.

Those scrolling functions come set from the Mouse Driver that the Browser then uses. So you need to first check your mouse Drivers are current and configured correctly. I know I have Logitech Mouse driver/Keyboard and in there it has scrolling feature also my mouse has a lock button so if you press to release the wheel will scroll freely without stopping til end of page but if locked will only scroll so far. Otherwise your mouse could also be defective causing to scroll farther then it should.

Kérdés tulajdonosa

It has nothing to do with the mouse driver, my mouse or anything else besides Firefox itself. It is a feature that is implemented in the browser and it has been there since the dawn of ages. There was a way to disable it with the smooth wheel addon, but as I have already said earlier, it doesn't work anymore in never Firefox versions.

It has nothing to do with the mouse driver, my mouse or anything else besides Firefox itself. It is a feature that is implemented in the browser and it has been there since the dawn of ages. There was a way to disable it with the smooth wheel addon, but as I have already said earlier, it doesn't work anymore in never Firefox versions.

Módosította: hypnotoad,

Kérdés tulajdonosa

It seems that I have managed to solve this. Here's what I've changed in about:config: mousewheel.min_line_scroll_amount;32 - to get a bigger scroll step, it's not exactly the same as in FF51 with Smooth Wheel addon, but it's very close general.smoothScroll.mouseWheel.durationMaxMS;200 - to remove this annoying "reverse acceleration" when you scroll the wheel slowly, if you could call it that toolkit.scrollbox.verticalScrollDistance;6 - setting this will change arrow keys amount of scroll lines to match mouse wheel setting after all the tampering

I think I will tamper more with the settings, but it's already good enough for me to use.

It seems that I have managed to solve this. Here's what I've changed in about:config: '''mousewheel.min_line_scroll_amount;32''' - to get a bigger scroll step, it's not exactly the same as in FF51 with Smooth Wheel addon, but it's very close '''general.smoothScroll.mouseWheel.durationMaxMS;200''' - to remove this annoying "reverse acceleration" when you scroll the wheel slowly, if you could call it that '''toolkit.scrollbox.verticalScrollDistance;6''' - setting this will change arrow keys amount of scroll lines to match mouse wheel setting after all the tampering I think I will tamper more with the settings, but it's already good enough for me to use.

Módosította: hypnotoad,