X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Nadogradi Firefox

Support Forum

When I play castle age on facebook, firefox only shows half the page, yet it works on chrome?

Posted

I play castle age on facebook, I've always used either google chrome or web3, but a friend suggested I use firefox multifox as I sometimes play a couple of friends accounts when they're working, everything worked brilliantly, I could change accounts with one click, fantastic! but now I can't play castle age on firefox at all as it only loads half the page!?

Could somebody help please?

Chosen solution

Hi all, thank you to all who tried to help me with my problem, just to let you know the problem is now solved. It was Avast, it was blocking certain parts of social network data, I disabled Avast and now it works perfectly, (it was ok before but a new update caused the problem).

Thanks again for all your suggestions and help :)

Read this answer in context 0
Post a Reply

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • VLC media player Web Plugin 2.1.0
  • 5.1.20913.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Proširenja

  • avast! Online Security 9.0.2006.53 (wrc@avast.com)
  • Multifox 2.0.6 (multifox@hultmann)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Default Manager 2.2 ({3252b9ae-c69a-4eaf-9502-dc9c1f6c009e}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 8-25-2010
  • driverDate2:
  • driverVersion: 8.15.10.2202
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1383074906
  • places.history.expiration.transient_current_max_pages: 98743
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1380660088

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Was this helpful to you? 0
Odgovor
jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

If the above suggestion does not resolve the problem, could you describe the problem in more detail? For example, is the game cut off on the right side, or on the bottom? If you right-click the game, does it appear to use the Flash plugin or the Java plugin? Does it make any difference if you reset the zoom level on the page using Ctrl+0 (that's a zero)?

Was this helpful to you? 0
Odgovor

Question owner

Thank you for your suggestion, I cleared the cache as you said but still exactly the same problem, but thank you anyway :)

Was this helpful to you?
Odgovor

Question owner

the top half of the page is shown, the bottom half is completely white, if I go back to my facebook home page I can see everything, but in castle age I only see the top half of the page. I've just spoken to a friend who also uses multifox, he said he can't get his to work with castle age anymore either, but his firefox works ok?? as for the plug in, when I cleared the cache it said it was waiting for the flash plugin to work

Was this helpful to you?
Odgovor
jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Helpful Reply

Do you think Multifox is a factor? You could disable it, or you could try Firefox's Safe Mode as a test to see whether disabling all extensions resolves the issue.

Firefox's Safe Mode is a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled *

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

* Flash and other plugins still run in safe mode.

Was this helpful to you? 1
Odgovor

Question owner

I don't think so as it was working fine until a few days ago, also when castle age won't work at all using firefox now, yet it was working perfectly, a friend recommended multifox as it enables me to have several accounts open at once, which is perfect for what I need, as I said, everything was working perfectly until a few days ago, there haven't been any windows updates so I can't even blame that! :)

Was this helpful to you?
Odgovor
cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

You can try is it works in a "New Private Window".

Note that Firefox 25 has been released, so you can check for updates in "Help > About".

Was this helpful to you?
Odgovor

Question owner

I just tried the private window with exactly the same results, also checked the updates and I'm using version 25.0

Was this helpful to you?
Odgovor
jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Possibly related:

I don't know whether you use any other Facebook games, but if so, do they have the same issue? By default, the space occupied by a plugin is not very tall. Style rules in the page generally define the height. Perhaps there is a problem with a Facebook style sheet (or an add-on that filters out some Facebook content)?

Did you try Firefox's Safe Mode as a test?

Was this helpful to you?
Odgovor

Question owner

I play a couple of other games on facebook, Ghost Saga, Avengers, Criminal case, they all work fine and show the full screen, it's only doing it with castle age, and only for the last few days, before that it was fine?

Was this helpful to you?
Odgovor

Chosen Solution

Hi all, thank you to all who tried to help me with my problem, just to let you know the problem is now solved. It was Avast, it was blocking certain parts of social network data, I disabled Avast and now it works perfectly, (it was ok before but a new update caused the problem).

Thanks again for all your suggestions and help :)

Was this helpful to you?
Odgovor
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.