Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Nadogradi Firefox

Support Forum

Tuvaro.com comes up when I select text and drag and drop to search, rather than google, my default search engine.


If I search via my address bar or the search engine bar, it uses the selected/default search engine, in this case google. If I search by selecting text and dragging/dropping it, it searches with tuvaro.com or proxy.allsearchapp.com. There is no toolbar installed, I've reset firefox, run in safemode, and run multiple malware scanners and I can't seem to correct this issue. I've also tried searching for both sites in about:config and using the searchreset extension.

All I can figure is that an issue I had a couple days ago with a browser hijacking changed some setting that only affects searches when I use the select/drag/drop function but nothing else.

Any assistance would be tremendously appreciated.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • GEPlugin
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • McAfee MSS+ NPAPI Plugin
  • 5.1.20125.0
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Adobe Shockwave for Director Netscape plug-in, version
  • Nexon Game Controller
  • Pando Web Plugin
  • DivX Plus Web Player version
  • Unity Player 3.4.2f3
  • Adobe Shockwave for Director Netscape plug-in, version
  • DivX VOD Helper Plug-in
  • np-mswmp


  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/


  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • FlashGot ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • NoScript 2.6.6 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Session Manager ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • DivX Plus Web Player HTML5 <video> ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • HP Smart Web Printing 4.51 (smartwebprinting@hp.com) (Inactive)
  • QuickDrag (quickdrag@mozilla.ktechcomputing.com) (Inactive)


  • incrementalGCEnabled: True


  • adapterDescription: AMD Radeon HD 6700 Series
  • adapterDescription2:
  • adapterDeviceID: 0x68b8
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion:
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6700 Series)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1367402892
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True


  • User JS: No
  • Accessibility: No
Giedrius_M 18 solutions 157 answers

Check user.js file in firefox data directory. Sometimes hijackers leave some settings there as well. Additionally, check if everything is removed from control panel and your plugin list

Question owner

No user.js file created. Does it in safe mode with all addons/plugins disabled.

Further note, only sends me to either site when I drag/drop a words/phrase that isn't a web page. Like if I highlight drag and drop youtube, it takes me to youtube.com. If I did the same on something that isn't a website, or some random string of letters, it searches one of the 2 aforementioned sites rather than using my default search engine.

Going to attempt to reset firefox again and see if I can make it stop via sheer willpower.

Edit: resetting did nothing :( Might try a system restore. Edit2: The only system restore date was from yesterday, which was after the problem appeared :( I've since tried spybot, gone through registry looking for anything with .com in it that I didn't recognise and reset firefox a third time. For the mean time I've just set Avast! to block both web pages. Dunno what else to try, honestly.

Modified by youogtit

sillymoy 2 solutions 19 answers

Tuvaro uninstall guide:


Make sure you did everything correctly.

Also, you may scan your computer with AdwCleaner.

  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can check the browser.search.selectedEngine pref on the about:config page.

Question owner

Adwcleaner shows every file as clean. Run through a couple of uninstall guides already and no luck.

I don't see a browser.search.selectedEngine entry in about:config. browser.search.defaultenginename is the closest I can find, and its entry is google.