Pretraži podršku

Izbjegni prevare podrške. Nikad te nećemo tražiti da nas nazoveš, da nam pošalješ telefonski broj ili da podijeliš osobne podatke. Prijavi sumnjive radnje pomoću opcije „Prijavi zlouporabu”.

Learn More

H.264/MP4 video will not play on my linux firefox installation

  • 6 odgovora
  • 13 ima ovaj problem
  • 327 prikaza
  • Posljednji odgovor od James

more options

hello,

I have firefox version 57.0 installed on centos version 7.4.1708, and I'm unable to view videos in H.264/MP4 format. what applications should I look for on my system? how can I configure my browser to load this type of format on my browser?

Izmjenjeno od James

Svi odgovori (6)

more options

You need to make sure you have packages like FFmpeg installed as Firefox has not used Gstreamer for a good while now for the HTML5 player.

You can check to see what your system supports at say https://www.youtube.com/html5/ as all check marks should be blue.

more options

Thanks for the quick reply, I have ffmpeg installed, however the youtube html checker has a red exclamation mark for "H.264" and "MSE & H.264" everything else has a blue check mark.

more options

All the codecs you need are in VLC as a player, unfortunately does not stick codecs in addons anymore. https://www.videolan.org/vlc/download-ubuntu.html

ffmpeg is most popular for Linux , you may want to see if there is updates and codecs always get corrupted.

Please let us know if this solved your issue or if need further assistance.

more options

thanks, I followed the steps to install the compiled version of vlc for centos on the vlc website. after the packages were installed, I am now able to view videos in H.264 format. thanks for the help.

more options

Great, Welcome. If there is something here to tick as Solved please do so as others can find this answer. Enjoy.

more options

Never needed to use any external software to make HTML5 player to work in Firefox and SeaMonkey on Linux as I have rarely seen VLC suggested for Linux users to use in this case.

If Firefox was still running when you installed the FFmpeg packages then perhaps you restarting Firefox at some point made it work and not due to vlc.

Izmjenjeno od James