Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm getting the message: Firefox (4.0) is not compatible with this version of MAC OSX (10.4.11); how can I go back to Firefox 3.6?

  • 1 प्रत्युत्तर दें
  • 5
  • 5 views
  • के द्वारा अंतिम प्रतियुतर TonyE

more options

Is Firefox 4.0 compatible with Mac OSX 10.4.11? If not, is there somewhere I can download the older version of Firefox 3.6 that worked fine with my Mac?

All Replies (1)

more options

Firefox 4 requires at least OS X 10.5 and an Intel Mac.

You can get the latest version of Firefox 3.6 from http://www.mozilla.com/en-US/firefox/all-older.html