Mozilla Support में खोजें

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can I turn OFF the search dropdown?

  • 7 प्रत्युत्तर
  • 10
  • 11 views
  • के द्वारा अंतिम प्रतियुतर FredMcD

more options

I recently had to reformat my computer and re-install Firefox. I notice that when I type in the address bar to go to a site like msn.com it drops down a search bar suggesting that I search with my default search engine. Well I know where I am going!!! I have turned OFF suggested sites, yet it still drops down a search bar below my address bar. Can I turn this off? It is distracting and annoying.

I recently had to reformat my computer and re-install Firefox. I notice that when I type in the address bar to go to a site like msn.com it drops down a search bar suggesting that I search with my default search engine. Well I know where I am going!!! I have turned OFF suggested sites, yet it still drops down a search bar below my address bar. Can I turn this off? It is distracting and annoying.

चुने गए समाधान

Thanks! but not quite sure we are on the same page. I was trying to hide everything under the address bar, the line with the globe to go to the site, and the line with the magnifying glass to search. I had turned off search suggestions as I type in the address bar, this helped, but it did not completely get rid of the list.

So I compared my settings from another pc, the settings matched (in the menus) then I did an about:config went to urlb and noticed some other settings were set to true, for example:

browser.urlbar.searchSuggestionsChoice

I toggled every "suggest" to False and now I no longer have the issue. Thanks for your help.

संदर्भ में यह जवाब पढ़ें 👍 4

All Replies (7)

more options

Type about:preferences#privacy<enter> in the address bar. At the bottom of the page, find Location Bar.

more options

FredMcD said

Type about:preferences#privacy<enter> in the address bar. At the bottom of the page, find Location Bar.

Yes, did the following and made sure all were unchecked, then what? remember this is a fresh install and 55.0.3 64 bit.

more options

Is the problem an explanatory line that is highlighted at the top of the drop down -- it tells you what Firefox will do if you press Enter at any given point while typing in the address bar -- or the new row of "one off" search buttons along the bottom of the drop-down?

There is a preference to hide the one-off button section:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.oneOffSearches preference to switch the value from true to false

more options

I think that is what I am trying to turn off. Here is a screenshot.

more options

Hi henryspr1, the top row of the drop-down is informational and tells you what should happen if you press Enter at that moment. The second line is... a suggestion from your default search engine, judging from the icon.

more options

चयनित समाधान

Thanks! but not quite sure we are on the same page. I was trying to hide everything under the address bar, the line with the globe to go to the site, and the line with the magnifying glass to search. I had turned off search suggestions as I type in the address bar, this helped, but it did not completely get rid of the list.

So I compared my settings from another pc, the settings matched (in the menus) then I did an about:config went to urlb and noticed some other settings were set to true, for example:

browser.urlbar.searchSuggestionsChoice

I toggled every "suggest" to False and now I no longer have the issue. Thanks for your help.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.