Mozilla Support में खोजें

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

High use of resources just after startup

  • 15 प्रत्युत्तर
  • 2
  • 11 views
  • के द्वारा अंतिम प्रतियुतर HubiKoshi

more options

Greetings. Recently my Firefox started acting a bit weird right after start up. More or less 30-40 seconds after I turn it on it starts to use up 20-30% of my CPU (i5) and starts hogging more RAM, it lasts for some 15-30 seconds, sometimes more and then everything goes back to normal. I turned off all my add-ons and plugins, nothing worked. I also made a new profile and it seems to be happening there too but for only a couple of seconds. I'm a little bit worried if this some virus or something else...

Greetings. Recently my Firefox started acting a bit weird right after start up. More or less 30-40 seconds after I turn it on it starts to use up 20-30% of my CPU (i5) and starts hogging more RAM, it lasts for some 15-30 seconds, sometimes more and then everything goes back to normal. I turned off all my add-ons and plugins, nothing worked. I also made a new profile and it seems to be happening there too but for only a couple of seconds. I'm a little bit worried if this some virus or something else...

All Replies (15)

more options

https://support.mozilla.org/en-US/kb/update-firefox-latest-version 49.0.2

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Yes, it still happens even in Safe Mode. I ran a thorough scan with AVG and Malwarebytes and they did not detect anything.

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Okay I did it and yes it still happens. I forgot to mention but I don't even need to enter any sites. I can turn it on and leave it in Firefox starter "page" and it will still happen.

more options

Hi   !
Would you take a look at the article: 'Firefox uses to many   CPU   resources  -  How to fix'
        http://mzl.la/1BAQIeY

more options

I tired all of that but unfortunately none of them worked. It's not even that Firefox uses a lot of resources, it only uses that 20-30% soon after startup and after that it's all okay but it worries me a bit because the browser isn't Doing anything that would warrant the resources used.

more options

Have you upgraded Firefox to 49.0.2 ?

more options

Yes, as a matter of fact I think the problem might have started after the update though I only noticed it on the Sunday evening. I even reinstalled Firefox but nothing changed.

more options

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste async and pause while the list is filtered (3) Double-click the dom.ipc.plugins.asyncdrawing.enabled preference to switch the value from true to false

This might not take effect until the next time you exit Firefox and start it up again.


One of the headline changes in Firefox 48-49 is e10s, which separates the browser interface process from the page content process. The performance impact of this can vary a lot between systems, so it would be helpful to know whether you have this feature turned on. To check that, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for Multiprocess Windows and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

To help evaluate whether that feature is causing this problem, you could turn it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?

more options

I tried both but there was no real change... For the second the multitasking windows was 0/1 (off) but I tried it anyway and it didn't work. Do you know whether this comes from Firefox itself or does it have some external cause? It doesn't seem to cause any real problems so if it's just a harmless issue I could just ignore it without fixing it.

more options

Hard to say until the cause is found. This could be a hardware issue.

more options

Greetings again. I think I might have found the source of my problem, or at least something connected to it. I activated Firefox with Resource Manager on, when Firefox started acting up I noticed that my hard drive also started working harder. So I monitored the Disk use and here are the results.

more options

Sorry for a second post. I ran Firefox with Adblock turned off and this time a different file appeared in Resource Monitor as dominant. The startupcache.4.little

more options

I called for more help.

more options

Curious thing. I was doing some experimenting on a fresh profile and... when I had Adblock Plus installed on it the issue was there, but on a smaller scale. But when I removed Adblock the problem disappeared. However when I removed Adblock from my main profile it didn't affect the problem at all...