Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Add-ons keep vanishing

  • 9 प्रत्युत्तर
  • 6
  • 62 views
  • के द्वारा अंतिम प्रतियुतर Anysia

more options

Out of the blue, my about:addons page started becoming depopulated. But as you can see by the attached file, the addons are installed. After a few restarts of Firefox, Firefox behaves as if it's a fresh install, with a tab for every extension asking if I want to install it. I select install/continue, restart, and then repeat. This problem has been going on for months. I have uninstalled, purged, deleted every aspect/file/folder of Firefox, including everything in the appdata folder that has to do with Mozilla (firefox) including the profile folder. I then did a clean install, from a fresh download and then install addons/extensions from Mozilla site only. It doesn't matter if I have one extension install, or all of them, or any particular one, this empty "about:addons" page will be empty.

I have tried with Firefox32 bit and 64bit, and this problem happens with them both. I have scanned for spyware/malware/virus.. nothing. And before someone says something wrong with my computer, this only happens with Firefox. It's not a corrupt profile, as all profiles were deleted prior to fresh install from new download.

It doesn't happen with Cyberfox and it's set up to use the exact same plugins/addons/extensions. I have discussed with with other people I know who experienced the same problem (they ended up switching to different browser, but I would prefer not to do that)

संलग्न स्क्रीनशॉट

All Replies (9)

more options

What is strange is that even though they are not listed, the Classic Theme restorer is still evident in the second screenshot.

Have you tried to disable addons one by one in the second senario (your second screenshot) to see if its an interaction between to add ons?

Or See if they are listed when you start Firefox in Safe Mode, even though they are signed, they should still show up.

On a side note, another thing I noticed about your profile is that your driver is black listed. I think you may be affected by the crash issue with nvidia, please make sure you are on 43.0.3.

more options

Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is affected.

You can disable this feature in "Options/Preferences > Privacy" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"
more options

It is possible that there is a problem with files in the profile folder that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.ini, extensions.sqlite) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox menu button/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

If this didn't help then delete addons.json and possibly prefs.js in case there is a problem with preferences.

You can use this button to go to the current Firefox profile folder:

more options

Cor-el - As I stated in my original post, I have already erased/purged/deleted every and anything Mozilla from the computer, including appdata/roaming/mozilla/profiles, and in the Program Files/Program Files (x86). Re-downloaded fresh copy of Firefox install. Then installed all SIGNED extensions. I read the FAQs that you have posted links to, and have done it all repeatedly. Tracking can't explain why this is happening, but it happens whether tracked or not.

guigs - Yes, I've spent months doing that. It doesn't matter if it's just one extension, or all of them, or any combination. Started in safe mode, same thing, no extensions listed. After a while, Firefox Extenstions list is depopuplated, and shortly after that happens, when I start firefox, all the extension tabs along the top as if they were just recently installed.

Regarding Nvidia driver - This problem has been happening for MONTHS, even before I updated my graphics drivers.

more options

I am having the exact same problem. I have a fresh Windows 10 install, fresh Nvidia drivers, fresh Firefox install, fresh add-ons installed, yet every few days to every few weeks, This is a bug that started a few months ago.

Let me know if this gets fixed.

more options

What security software do you have?

Do you run any cleanup software every few weeks (e.g. once a month) that might delete or corrupt files in the Firefox profile folder?

It is best to exclude the Firefox profile folder from all such programs to avoid such issues.

more options

Ok, repeating myself, but here goes: I have tried running it without any security software (yes, that mean I uninstalled the security software, in this case, Malwarebytes and Iolo System Shield) I have tried running it with both reinstalled, with the Mozilla/Firefox folders/directories whitelisted/excluded.

No, I don't run clean up software because it bollixes integral software, causing me to have to uninstall it/reinstall it after contacting their support to reset activations.

I have been working on this for a few months, and as I originally stated in my first post. As much as I do appreciate the suggestions, they are suggestions I already stated I had tried.

more options

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

cor-el As I orginally posted, I already did all of that. I have uninstalled, purged, deleted every aspect/file/folder of Firefox, including everything in the appdata folder that has to do with Mozilla (firefox) including the profile folder. I then did a clean install, from a fresh download and then install addons/extensions from Mozilla site only. It doesn't matter if I have one extension install, or all of them, or any particular one, this empty "about:addons" page will be empty.

I have tried with Firefox32 bit and 64bit, and this problem happens with them both. I have scanned for spyware/malware/virus.. nothing. And before someone says something wrong with my computer, this only happens with Firefox. It's not a corrupt profile, as all profiles were deleted prior to fresh install from new download.