Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Flashing above the menu bar - "Not Responding"

  • 11 प्रत्युत्तर
  • 2
  • 24 views
  • के द्वारा अंतिम प्रतियुतर jscher2000

more options

I recently re-installed Firefox after obtaining a bunch of adware/malware. I've successfully cleaned my PC of all the junkware, but now, every time I click a link or Firefox is loading something, the browser flashes. It's almost like it's flickering above the menu bar and says "Not Responding." I've tried using Firefox in safe mode, which didn't help, and I've disabled "hardware acceleration if available." Didn't fix it. I have also uninstalled my anti-virus suite, just to see if it was that new program causing the problem. This did not fix it either. This is my favorite browser and I would rather not have to switch. Please help!

All Replies (11)

more options

even though you have recently re-installed firefox, did you remove all add-ons and extras? i had something similar to this that made the whole screen a "link" that would crash firefox. i fixed it by removing deleting the mozilla folders in C:\Users\USERNAME\AppData\Local C:\Users\USERNAME\AppData\Roaming then reinstalling

more options

Bear in mind, if you delete the folder under Roaming without having a backup or previously setting up Sync, you will lose your bookmarks and saved passwords.


Could you do this three-minute experiment:

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Don't delete anything here!

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like TEST111615, and skip the option to relocate the profile folder. After creating the profile, select it and start Firefox in that profile.

Any difference?

When returning to the Profile Manager, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

Note that you lose all personal data in the Firefox profile folder if you remove "\AppData\Roaming\Mozilla\Firefox"

more options

I tried this and now the problem is worse.

Djman7000 said

even though you have recently re-installed firefox, did you remove all add-ons and extras? i had something similar to this that made the whole screen a "link" that would crash firefox. i fixed it by removing deleting the mozilla folders in C:\Users\USERNAME\AppData\Local C:\Users\USERNAME\AppData\Roaming then reinstalling
more options

scjesb said

I tried this and now the problem is worse.

What is the problem now, has it changed?

If you use the Recycle bin, can you restore those folders?

more options

At this point, when I use the sync function, that is when the flashing of the browser gets out of control and the browser becomes unusable (typing isn't possible, as the flashing moves the selected field). I am currently using a default profile without the sync function active and everything is a bit faster and the flashing has stopped for now. I've tried going to various sites, including high traffic ones, and the problem seems to have subsided.

Since I had so many malware/adware/spyware programs on my computer, once they were all deleted, I reinstalled Windows 10. I have only the basic programs and apps on my PC so I'm really not sure what this issue could be. The problem only exists in Firefox and within Sync. Thunderbird is fine.

jscher2000 said

scjesb said
I tried this and now the problem is worse.

What is the problem now, has it changed?

If you use the Recycle bin, can you restore those folders?

more options

I take it back. It's still happening, but the flashing is only a small issue. It's still going on though not inhibiting browser functions.

scjesb said

At this point, when I use the sync function, that is when the flashing of the browser gets out of control and the browser becomes unusable (typing isn't possible, as the flashing moves the selected field). I am currently using a default profile without the sync function active and everything is a bit faster and the flashing has stopped for now. I've tried going to various sites, including high traffic ones, and the problem seems to have subsided. Since I had so many malware/adware/spyware programs on my computer, once they were all deleted, I reinstalled Windows 10. I have only the basic programs and apps on my PC so I'm really not sure what this issue could be. The problem only exists in Firefox and within Sync. Thunderbird is fine. jscher2000 said
scjesb said
I tried this and now the problem is worse.

What is the problem now, has it changed?

If you use the Recycle bin, can you restore those folders?

more options

Okay, while I don't know what is causing the "Not Responding" episodes, we have had numerous reports of issues with the Flash plugin recently. Since Flash is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting:

(1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it.

To set "Ask to Activate", open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate".

With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page.

The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.)

The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash.

If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently.

But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later.

(2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

more options

Since I just reinstalled Windows 10 and Firefox, Shockwave Flash isn't installed yet on my PC, so that can't be the issue. The plugins I do have are "Primetime Content Decryption Module" and "OpenH264 Video Codec." Neither of these have the option to disable.

The problem increases in this default user profile when I open more tabs. If I attempt to open one tab while another one is loading, it stalls the entire system down.

I just disabled the "hardware acceleration" component, so I'll see if that helps for now and report back.

jscher2000 said

Okay, while I don't know what is causing the "Not Responding" episodes, we have had numerous reports of issues with the Flash plugin recently. Since Flash is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting: (1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.) The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. (2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.
more options

So the "hardware acceleration" function being off doesn't help the flashing of the "not responding" in the menu bar.

scjesb said

Since I just reinstalled Windows 10 and Firefox, Shockwave Flash isn't installed yet on my PC, so that can't be the issue. The plugins I do have are "Primetime Content Decryption Module" and "OpenH264 Video Codec." Neither of these have the option to disable. The problem increases in this default user profile when I open more tabs. If I attempt to open one tab while another one is loading, it stalls the entire system down. I just disabled the "hardware acceleration" component, so I'll see if that helps for now and report back. jscher2000 said
Okay, while I don't know what is causing the "Not Responding" episodes, we have had numerous reports of issues with the Flash plugin recently. Since Flash is used pervasively through the web, I suggest the following to minimize potential issues with Flash during your troubleshooting: (1) To avoid unnecessary pain on sites where Flash is not actually essential, try setting Flash to Click-to-Play ("Ask to Activate"). This will delay Flash from starting on a page until you approve it. To set "Ask to Activate", open the Add-ons page using either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins. Look for "Shockwave Flash" and change "Always Activate" to "Ask to Activate". With this setting, when you visit a site that wants to use Flash, you should see a notification icon in the address bar and usually (but not always) one of the following: a link in a dark gray rectangle in the page or an infobar sliding down between the toolbar area and the page. The plugin notification icon in the address bar typically looks like a small, dark gray Lego block. (If it's red, Flash needs updating.) The delay in activating Flash can help distinguish between problems caused on initial page load, styling, and script activation vs. loading/running Flash. If you see a good reason to use Flash, and the site looks trustworthy, you can go ahead and click the notification icon in the address bar to allow Flash. You can trust the site for the time being or permanently. But some pages use Flash only for tracking or playing ads, so if you don't see an immediate need for Flash, feel free to ignore the notification! It will just sit there in case you want to use it later. (2) A common cause of unresponsive script errors on Windows Vista and higher is the protected mode feature of the Flash player plugin. That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:
  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons
In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.
more options

Sorry, this doesn't sound like anything I've heard of before. A couple thoughts: