Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Java runtime environment will not install

  • 4 replies
  • 54 have this problem
  • 13108 views
  • Last reply by cor-el

more options

When going to pogo.com the address bar indicates that Java Runtime Environment needs to be installed for the browser. When I go ahead to install the plug-in it indicated that it could not and to manually download and install it. I did. Restarted the computer and still the plug-in wants to install. Uninstalled then Re installed Firefox and the problem still exists. Uninstalled Java and reinstalled and still yet it does not work.

All Replies (4)

more options

To see whether Java is installed in the location that Firefox checks for it, can you open this folder:

C:\Program Files (x86)\Java\jre7\bin\plugin2\

The plugin file is named npjp2.dll

If that's not there, something is failing with the Java installation. You can try the "offline" installer (large download). Make sure to grab the 32-bit installer, since Firefox only uses 32-bit plugins.

http://www.java.com/en/download/manual.jsp

Or is that the one you tried?

Modified by jscher2000

more options

If the DLL file is where it should be, could you step through a few different checks:

(1) Add-ons page — disabled plugins

Check to make sure Java(TM) Platform SE 7 is not set to "Never Activate" because that disables the plugin and hides it from websites.

Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins. Check the grayed out area at the bottom.

If there's no sign of it on the Add-ons page...

(2) Confirm that Firefox is scanning the registry for plugins

Firefox finds the Java plugin from a registry entry. Some users have the scanning turned off for some reason. Here's how to check and fix that:

(A) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(B) In the filter box, type or paste scan and pause while the list is filtered

(C) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default.

If you changed this setting, exit and restart Firefox to trigger another scan.

If you check the Add-ons page again, success?

If Firefox is set to scan but still does not find Java and list it on the Add-ons page...

(3) Remove Firefox's plugin registry file

Sometimes the pluginreg.dat file becomes corrupted. You can remove it and have Firefox re-scan for plugins. As a side effect, any plugins you have disabled on the Add-ons page probably will be re-enabled, so you'll need to go back to that page one more time.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, switch back to Firefox and Exit (either Firefox button > Exit or File menu > Exit)

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Restart Firefox. (If you want to restore your previous non-private session, use History > Restore Previous Session.)

When you return to the Add-ons page, is Java finally there?

Modified by jscher2000

more options

Last but perhaps not least, it is possible to block the Java plugin from appearing in the browser using a setting in the Windows Control Panel.

Windows Control Panel > Java (32-bit)

On the Security tab, there is a checkbox to enable Java to run in web browsers.

more options