X
Tap here to go to the mobile version of the site.

Support Forum

you tube videos crash after few seconds in Firefox

Posted

I have got the latest flash version and Firefox. You tube videos keep crashing after a couple of seconds. Very occasionally the same one that crashes will play . I have been trying everything for about 2 days including reinstalling firefox with new profile, uninstalling flash with Adobe's uninstall program and every other suggestion I have found on the internet but nothing seems to make any difference. I am thinking of using Chrome which does work but I do not want to. Previously it worked fine in Firefox with hardware acceleration. I hope someone can find a solution before I tear all my hair out. Thank you

I have got the latest flash version and Firefox. You tube videos keep crashing after a couple of seconds. Very occasionally the same one that crashes will play . I have been trying everything for about 2 days including reinstalling firefox with new profile, uninstalling flash with Adobe's uninstall program and every other suggestion I have found on the internet but nothing seems to make any difference. I am thinking of using Chrome which does work but I do not want to. Previously it worked fine in Firefox with hardware acceleration. I hope someone can find a solution before I tear all my hair out. Thank you

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Bookmark Favicon Changer 1.74 (bookmarkfaviconchanger@sonthakit)
  • FillForm 1.2.10 (fillforms@symental.com)
  • Flashblock 1.5.17 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Mozilla Archive Format 3.0.0 ({7f57cf46-4467-4c2d-adfa-0cba7c507e54})
  • Saved Password Editor 2.7 (savedpasswordeditor@daniel.dawson)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • FEBE 7.3.0.1 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3}) (Inactive)
  • Greasemonkey 1.11 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • Image and Flash Blocker 0.7 (imgflashblocker@shimon.chohen) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4550
  • adapterDescription2:
  • adapterDeviceID: 0x9540
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 1-26-2011
  • driverDate2:
  • driverVersion: 8.821.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4550 )
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.newtab.url: https://www.google.com/webhp?complete=0
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.search.suggest.enabled: False
  • browser.search.useDBForOrder: True
  • browser.sessionstore.max_tabs_undo: 0
  • browser.startup.homepage: https://www.google.co.uk/webhp?complete=0
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.tabs.onTop: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • font.internaluseonly.changed: True
  • keyword.URL: www.google.co.uk
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • network.protocol-handler.expose.mailto: True
  • places.database.lastMaintenance: 1378916248
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 80491
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.flash: 2
  • plugin.state.npdrmv: 0
  • plugin.state.npdsplay: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.nppdfxcviewnpplugin: 0
  • plugin.state.nppicasa: 0
  • plugin.state.npwmsdrm: 0
  • plugin.state.npwpf: 0
  • plugins.notifyMissingFlash: False
  • privacy.clearOnShutdown.offlineApps: True
  • privacy.cpd.offlineApps: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378802629

Misc

  • User JS: No
  • Accessibility: No
Andrew
  • Moderator
275 solutions 3563 answers

Hello,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

Hello, Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.

Question owner

Thanks but I had already tried this and it made no difference. Besides, I have been playing youtube videos for years with hardware acceleration on and without any problems. I have noticed that the crashes seemed to occur when there was an advert at the beginning. The one that kept crashing is at http://www.youtube.com/watch?v=ab9176Srb5Y but It does seem to be playing OK now so perhaps the problem has sorted itself out as I have not done anything else to my system . I shall keep an eye on it. Thanks

Thanks but I had already tried this and it made no difference. Besides, I have been playing youtube videos for years with hardware acceleration on and without any problems. I have noticed that the crashes seemed to occur when there was an advert at the beginning. The one that kept crashing is at http://www.youtube.com/watch?v=ab9176Srb5Y but It does seem to be playing OK now so perhaps the problem has sorted itself out as I have not done anything else to my system . I shall keep an eye on it. Thanks

Helpful Reply

I have just tried again and it is still crashing most of the time. I have also installed Google Chrome and cannot get it to crash at all with hardware acceleration on. The latest crash was after about 1/2 second

I have just tried again and it is still crashing most of the time. I have also installed Google Chrome and cannot get it to crash at all with hardware acceleration on. The latest crash was after about 1/2 second
Andrew
  • Moderator
275 solutions 3563 answers

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash. #Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports. #Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here. Thank you for your help! More information and further troubleshooting steps can be found in the [[Firefox crashes]] article.

Question owner

No reports are generated. Has anyone else tried this youtube link ?

No reports are generated. Has anyone else tried this youtube link ?

Question owner

I seem to have found the solution myself . I tried disabling the Firefox plugin container by setting dom.ipc.plugins.enabled to "false" and so far no videos have crashed

I seem to have found the solution myself . I tried disabling the Firefox plugin container by setting dom.ipc.plugins.enabled to "false" and so far no videos have crashed
justjca 0 solutions 1 answers

I had the exact some problem and I accidently solved it. While looking for a browser tweak, I came across an "about:config" tweak site. I applied it to Firefox and it solved the problem. I had tried absolutely everything I could find, even uninstalling Firefox browser and reinstalling it...nothing worked. Here is the link. Of course, understand, one must be very careful when utilizing or changing or adding to about:config. http://cnettv.cnet.com/quick-tips-speed-up-firefox-page-display/9742-1_53-50002642.html

I have no idea why it solved the problem of all my You Tube videos hanging up...but it did. Be careful and good luck...Justjca

I had the exact some problem and I accidently solved it. While looking for a browser tweak, I came across an "about:config" tweak site. I applied it to Firefox and it solved the problem. I had tried absolutely everything I could find, even uninstalling Firefox browser and reinstalling it...nothing worked. Here is the link. Of course, understand, one must be very careful when utilizing or changing or adding to about:config. http://cnettv.cnet.com/quick-tips-speed-up-firefox-page-display/9742-1_53-50002642.html I have no idea why it solved the problem of all my You Tube videos hanging up...but it did. Be careful and good luck...Justjca
Chromeheads 0 solutions 1 answers

Go to help menu and select restart Firefox with add-ons disabled, then you should be able to watch you tube vids. Then enable the add on's you want.

Go to help menu and select restart Firefox with add-ons disabled, then you should be able to watch you tube vids. Then enable the add on's you want.