X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why do PDF-linked files on my website appear off center when opened?

Posted

I have created a website (not yet published) in which I have linked some PDF files. When I view these files in preview mode, the file pages all appear off center, i.e. they are positioned to the right on the page with a wide, blank margin on the left. This only occurs when I view them in Mozilla Firefox, not in other browsers such as Internet Explorer and Google Chrome. What might be causing this and how can I rectify it?

Chosen solution

I personally hate how browsers are defaulted to open .pdf documents in the browser. You can set it to download the document in Firefox then automatically open it in Adobe Reader solving your viewing issue.

To do this click on the Orange FireFox icon on the top left. (If you have the menu bar set up click the tools button.)

Now click Options. Choose the Applications tab. Scroll down to Portable Document Format. To the right click the dropdow list. Choose other. Then choose Adobe Reader from the list. Obviously this means you have Adobe Reader installed. Do not choose Adobe Reader in browser as that just means it will open with Adobe in the Browser. Which can sometimes cause Firefox to crash or stall out if the PDF is to big. I hope this helps.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • GEPlugin
  • 4.1.10329.0
  • Google Updater pluginhttp://pack.google.com/
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • avast! Online Security 8.0.1489 (wrc@avast.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82845G/GL/GE/PE/GV Graphics Controller
  • adapterDescription2:
  • adapterDeviceID: 0x2562
  • adapterDeviceID2:
  • adapterDrivers: ialmrnt5
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 6-21-2005
  • driverDate2:
  • driverVersion: 6.14.10.4342
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRendererMessage: [u'']
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1374689540
  • places.history.expiration.transient_current_max_pages: 26792
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1372971991

Misc

  • User JS: No
  • Accessibility: No
Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Helpful Reply

hmm are you using the builtin PDF viewer (PDF.js), refer to here to go back to the regular Adobe Acrobat PDF viewer.

Question owner

As far as I can tell, I am using Adobe Acrobat Reader XI (11.0.03). I don't know if this Is the Plug-In (PDF.js) or regular PDF viewer. Please advise.

However, when I tried viewing my website using Mozilla Firefox but on another computer, the problem never came up. The text on the page was perfectly centered. That computer was also using the same Acrobat Reader XI version as above. What does this suggest?

cor-el
  • Top 10 Contributor
  • Moderator
10777 solutions 97000 answers

Helpful Reply

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

Check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

Techuma318 1 solutions 5 answers

Chosen Solution

I personally hate how browsers are defaulted to open .pdf documents in the browser. You can set it to download the document in Firefox then automatically open it in Adobe Reader solving your viewing issue.

To do this click on the Orange FireFox icon on the top left. (If you have the menu bar set up click the tools button.)

Now click Options. Choose the Applications tab. Scroll down to Portable Document Format. To the right click the dropdow list. Choose other. Then choose Adobe Reader from the list. Obviously this means you have Adobe Reader installed. Do not choose Adobe Reader in browser as that just means it will open with Adobe in the Browser. Which can sometimes cause Firefox to crash or stall out if the PDF is to big. I hope this helps.

Question owner

Thanks a lot. Your recommended solution did the trick. I appreciated the clarity of your instructions.

Interestingly, though, before I tried your solution, I opened my website using Mozilla Firefox on another computer and the problem didn't exist, even though I was still opening the PDF in the browser.

Question owner

Thank you for your suggestions. I have used them, along with the other recommendations. They problem appears to be solved.

Ash_ 0 solutions 1 answers

Hi there.

I have the same problem ! On 25 SAME iMac with the same version of Firefox, and the same pluggins, I have 1 computer which display SOME pdf not properly : as explained, the PDF is cropped on the left, with a blank margin (shifted, not centered).

NB : - if I save the PDF, its OK, the file is good. - On the others 24 computers, the pdf looks nice. - If I user Adobe Reader (or similar software), the pdf looks nice too.

I'm a web developper, and I really want to know, to understand the problem, not avoid it by changing the default PDF viewer.

Does anyone have more information about this issue ?

Thanks a lot ! Ash_