Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Embedded images not displayed in Gmail

  • 27 replies
  • 42 have this problem
  • 17376 views
  • Last reply by moz101mo

more options

I use Gmail and occasionally receive emails which contain embedded images rather than attachments. These images do not appear when I use Gmail from Firefox, but they do appear when I use Gmail from Chrome or IE. If I forward the mail then the images appear in the forward mail window. Have tried all of the recommended actions but with no success.

All Replies (20)

more options

By default, Gmail should prompt you to show embedded images, but if you've emailed the sender at least twice before, the images are displayed automatically. I don't know why that would work differently in Firefox than in other browsers, but can you see any indication that the page is requiring you to approve displaying the images? (Google help page: Display images from certain senders - Gmail Help.)


To test whether one of your extensions is interfering, could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?


Finally, you might already have reviewed this article, but just in case: Fix problems that cause images to not show?

more options

Thanks for the suggestions, but as I said in my original post I have tried all of the recommended actions. The problem is sporadic and I have in the past been able to view embedded images sent from the same source (a hotmail account). The fact that it works in Chrome and IE would suggest that there is no problem with my Gmail settings.

more options

It may well be specific to the problem messages. Each browser has a different layout engine and Firefox sometimes stops showing content if the HTML of a web page is very deeply nested. This shouldn't happen if someone composes a message from scratch straight through, but if they were forwarding something that had already been forwarded many times or pasting something from the web or doing a lot of formatting changes, in those cases Firefox might not display the content.

This issue was noted in one message sent by one Hotmail user to another earlier this year (hotmail emails not displaying fully -- I examined the message and can confirm that the problem was the deep nesting of tags, but I'm not sure what caused it in that case).

I don't know whether this is in the bug tracking system.

more options

I forwarded the mail to my hotmail account and discovered the same problem. The image displays on Chrome and IE, but not Firefox. So the problem is not restricted to Gmail.

more options

Hi 2dealsok, is your problem also with messages sent from a Hotmail or Live.com/Outlook.com account?

more options

As far as I can tell the message is not deeply nested.
WLM shows the source as:-

Delivered-To: xxxxxxxx@gmail.com
Received: by 10.43.94.199 with SMTP id bz7csp40571icc;
        Sun, 16 Jun 2013 02:39:52 -0700 (PDT)
X-Received: by 10.182.87.42 with SMTP id u10mr6139815obz.73.1371375592023;
        Sun, 16 Jun 2013 02:39:52 -0700 (PDT)
Return-Path: <xxxxxxxx@hotmail.com>
Received: from blu0-omc4-s13.blu0.hotmail.com (blu0-omc4-s13.blu0.hotmail.com. [65.55.111.152])
        by mx.google.com with ESMTP id ke2si5905781obb.71.2013.06.16.02.39.51
        for <multiple recipients>;
        Sun, 16 Jun 2013 02:39:52 -0700 (PDT)
Received-SPF: pass (google.com: domain of xxxxx2@hotmail.com designates 65.55.111.152 as permitted sender) client-ip=65.55.111.152;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of xxxx2@hotmail.com designates 65.55.111.152 as permitted sender) smtp.mail=xxxxx2@hotmail.com
Received: from BLU169-W112 ([65.55.111.135]) by blu0-omc4-s13.blu0.hotmail.com with Microsoft SMTPSVC(6.0.3790.4675);
	 Sun, 16 Jun 2013 02:38:45 -0700
X-TMN: [XfAX/85Y6Vud1l3TP4s7qob6xIIXANNo]
X-Originating-Email: [xx2@hotmail.com]
Message-ID: <BLU169-W11292064DF38C1B7D043435F7820@phx.gbl>
Return-Path: xx@hotmail.com
Content-Type: multipart/alternative;
	boundary="_f29e433f-6362-4625-9330-42966b35696b_"
From:xxx <xxxx@hotmail.com>
Subject: -- Some Info On Alcohol --
Date: Sun, 16 Jun 2013 19:38:44 +1000
Importance: Normal
In-Reply-To: <BAY175-W19A7DD49648193A2DFFD6EA4800@phx.gbl>
References:
 <2B96B1A460474DD78F1E231213DFC381@GillianHP>,<8D033C0D084229B-DE8-1E60F@Webmail-d108.sysops.aol.com>,<8D033DF86AAF4A0-28DC-2701E@webmail-d269.sysops.aol.com>,<DUB118-W4484130D946BA512BA9DBCDC840@phx.gbl>,<BAY175-W19A7DD49648193A2DFFD6EA4800@phx.gbl>
MIME-Version: 1.0
Bcc:
X-OriginalArrivalTime: 16 Jun 2013 09:38:45.0232 (UTC) FILETIME=[4B986700:01CE6A75]

--_f29e433f-6362-4625-9330-42966b35696b_
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable


=20
Subject: -- Some Info On Alcohol --
Subject: FW: Alcohol

Modified by cor-el

more options

Hi HairyScot, could you try this: click Forward, then right-click the image that isn't visible in the received message and click Inspect Element. This should display the <img> tag in the context of the HTML code. The nesting level is shown by how indented the image is from the left. I can't think of a more convenient way to extract that information. Maybe a script? Hmmm...

Edit: I tried this in my sample "known problem" message and the Inspector wasn't able to even dig deep enough to access the invisible element.

Modified by jscher2000

more options

Have attached PNG file showing what appears when I click Inspect Element

more options

Those images may be embedded as CID (Content-ID; src="cid:image") and that may not work in Firefox.
In that case you need to save the email and open this eml file in an external email program.

more options

I use the DOM Inspector and have the indentation disabled, so the DOM tree shows as a small column.
That makes it more difficult to see where things belong, but allows me to keep the DOM Inspector window small.

#trDOMTree treechildren::-moz-tree-indentation {width:0px!important}
more options

Hi HairyScot, that's what I suspected, Firefox gives up on rendering the content after a certain depth.

Since Firefox introduced the stricter HTML5 rendering engine a couple years ago, some web pages exhibit this problem. With webpages, it's usually programmer error, but with Hotmail messages, I don't know what is causing it. Nor do I know of a good fix because users do not have direct access to edit the HTML of email messages and might not even be aware that content is missing.

more options

Example of related problem with web page: text is missing from webpage. While web pages might not present a strong case for changing the browser, since the developer is chiefly responsible, email is different.

I found an open bug report: 512605 – [HTML5] HTML5 parser gives up easily with deeply nested tags. In viewing related old bugs, it seems that allowing for an unlimited depth can crash Firefox, so it was capped at approximately 200.

This fragility is annoying. Perhaps it is time to reconsider some kind of solution for this?

Note about the bug system: If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See:

more options

Hi jscher200, Thanks for all the info.

One further question:- Why is that the image appears when I select "forward"?

more options

I've been having the same problem lately of images not showing up in some of my Hotmail/Outlook emails (but not all of them). They will, however, show up when accessed with I.E. and Chrome, just not with Firefox. I'm wondering if this could be corrected if I uninstalled/reinstalled Firefox. I'll wait until I read more responses below before trying that.

Modified by Maurita

more options

yes this bug is a pain and as mentioned most people wont even know theres a problem. I found it somewhat amusing that my previous account herein had expired so when I opened another the confirmation email of course didnt show either(see above). Actually its becoming very bothersome and annoying. I never noticed it on version 21 or previous. And as mentioned it doesnt happen with any other browser. I find that depressing as a firefox fan. It is a firefox problem. And not related to any add-ons or settings. and as mentioned it shows fine in forward window. using Arch-linux 64 bit firefox 22.....dammit!

more options

here is the 3 emails scrots from mozilla's own confirmation Email as it appeared on Gmail.com original /reply and /forward where finally the embedded pics show;

happens only on firefox with or without addons 
Arch-linux FF22  amd64
  very annoying and most people dont even know.....yet at least.

https://support.cdn.mozilla.net/media/uploads/images/2013-07-28-18-29-26-d7eff9.png

https://support.cdn.mozilla.net/media/uploads/images/2013-07-28-18-29-36-4f808f.png

https://support.cdn.mozilla.net/media/uploads/images/2013-07-28-18-29-46-72795c.png

more options

I forward my problem email to yahoo mail, no problem viewing. I forward to another gmail, same problem when clicking on "View all images".

@jescher2000, happy to forward you problem emails.

more options

Hi onix, I'm not familiar with the "View all images" feature. Where would I find that?

more options

At home I use Thunderbird where the problem doesnt exist......

   but its a pain when I access elsewhere on a machine I dont own.
more options

View images link is at the bottom of the gmail text section and before the in-line images appear. See attachments, View images sends you to the googleusercontent page.

  1. 1
  2. 2