X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the new built-in PDF viewer, but still be able to use the Adobe in-browser PDF viewer?

Posted

I updated Mozilla yesterday and as it happened, this new PDF viewer it magically came with doesn't cooperate with the sites I need to use for my workplace. I want the old way of viewing PDF's back, or just to be able to disable the built-in PDF viewer so that I can use the Adobe PDF viewer and see my files once again. I found a way to disable all PDF viewers, through about:config, but now I have to download the PDF's to my desktop to even view them and this doesn't exactly flow with my work. Please help!

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • 4.1.10329.0
  • RayV Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97057 answers

Helpful Reply

See:

You can set the pdfjs.disabled pref to true on the about:config page.

philipp
  • Top 10 Contributor
  • Moderator
2054 solutions 8922 answers

Helpful Reply

hello, go to firefox options > applications & define the default action for the portable document format (pdf).

View PDF files in Firefox without downloading them

Question owner

Thank you both, I really appreciate your help and my PDF viewer is back to normal now.

Axis 2 solutions 49 answers

I have found that all one needs to do is to go into tools/options/applications and change "Preview in Firefox" to "Use Adobe Acrobat (in Firefox") and you can easily change back to the previous mode.

I also actually love the Preview in Firefox, it allows you to open links in a Adobe document in a new tab and other sweet things.

mackay 0 solutions 4 answers

My default in tools> options > applications of "Save File" was changed when I upgraded to Firefox 19.0 on Win 7. I changed them back to "Save File" closed Firefox and tried do download with the intention of the pdf being saved and it came up in the built in viewer. What can I do to restore my original condition

Axis 2 solutions 49 answers

Hi mackay--

Two things. Didn't your pdf applications in tools>options have the option of "Use Adobe Acrobat (in Firefox")? If, so you can always toggle back to the "old style version by setting that instead of "Preview in Firefox".

Second, even in the PDF Viewer, there is an option to "Download" in the in the upper right of the Viewer. Are we seeing the same stuff?

Regards, Axis

mackay 0 solutions 4 answers

Hi Axis

Thanks for the info. I cannot seem to have an option of "Use Adobe Acrobat (in Firefox")? The choices in tools> options > applications 1 Always Ask 2 Save File 3 Other ... Other when clicked on gives a list of programs to open it similar to Open With in the Context Menu

There is a download button in the pdf viewer but I do not want to wait and take up memory for a 700 page pdf and then save it. Many of my pdfs are 2Mb plus with graphics

Modified by mackay

Axis 2 solutions 49 answers

Hi again mackay--

Somewhere in fooling around and learning about this new PDF Viewer, I tried various things, not because I don't like it but because I wanted to know how to turn it on or off.

At one point I did the " about:config thing " and set pdfjs.disabled to "true." I may have also deleted the mimetypes.rdf with browser "exited" (not just closed with the "X" button) and then reopened the browser.

It may have been on reopening the browser that I had "back" the "Use Adobe Acrobat (in Firefox") as an option (kind of hard to remember exactly which steps and order I did. Then I set the about:config thing " and set pdfjs.disabled to back to "false." Then I had both options. (???)

I hope that helps but I didn't do more with play around with it till I ended up with all the options back. Luckily, I had backed up my profile folder before I started playing with it, so if I got stuck I could just "exit" FF and replace my whole profile folder. But I can't absolutely say what order I did things in to get it this way...hope that helps but I can't guarantee anything. Good luck!

[edit: it "sounds like" you may just want to have "always ask" as your option? If that is true it may just try setting the about:config to set pdfjs.disabled to "true." Exit and reopen and see if what you get...thinking about your post it sounds like you don't want (???) the Adobe Reader either. I am not sure what "it was like" for your before you got FF 19.]

Regards, Axis

Modified by Axis

mackay 0 solutions 4 answers

Hi Axis

Problem solved - Thank goodness. Yes I do not want to view pdfs before or after ver 19.0

I thought that "Adobe Acrobat Document" covered all *.pdf files as the categories for Applications seem to be grouped on the file extension within the category. But I had found a "Portable Document File (PDF)" where the action was not "Save File" near the bottom of the long list. Duly changed and back to normal. Since Win 3x days I have always had the full version.

Thanks for your help. When I saw pdfjs I thought that I had seen it as one of the ones that I had changed an in checking I accidentally clicked on the bar to change the category index and then saw the PDF tag.

BTW In the meantime I downloaded a pdf file which came into the viewer and was read as dvi or something like that and a horribly bloated file size when I saved it & with the address in the header and poor quality overall. I downloaded the real thing in Opera with good pdf quality and 1/3 of the file size.

Thanks again

Axis 2 solutions 49 answers

Hi again mackay--

Your point about:

"I thought that "Adobe Acrobat Document" covered all *.pdf files as the categories for Applications seem to be grouped on the file extension within the category. But I had found a "Portable Document File (PDF)" where the action was not "Save File" near the bottom of the long list. Duly changed and back to normal."

Is VERY important! I got stumped by that too, finding the Abobe "Portable Document File (PDF)" down near the bottom of the applications screen. I am posting this so everyone can see that they should scroll down until they see "Portable Document File (PDF)."

Thanks for making that point here for others.

mackay 0 solutions 4 answers

Hi Axis

Your comment : Is VERY important! I got stumped by that too, finding the Abobe "Portable Document File (PDF)" down near the bottom of the applications screen. I am posting this so everyone can see that they should scroll down until they see "Portable Document File (PDF)."

I had mine sorted alphabetically an I thought for some of the files it was roughly sorted by extension. Having a column for the file extension would make it simpler as one could then sort on it. As the number of file types grows there are overlaps in file extensions. eg .dat can be text data files or music files.

Even better leaving things unchanged and letting those who want to use the feature to turn it on.

Steve3743 0 solutions 6 answers

To disable and fully revert back to Adobe Reader you must follow these steps that worked for me and will also, work for you.

  1. Go to about:config
  2. Search pdf
  3. Put pdfjs.disabled to True
  4. There will be a file on that list with the string:

application/pdf,application/vnd.fdf,application/vnd.adobe.xdp+xml,application/vnd.adobe.xfdf

Double Click on the file and remove the string; leave it blank and restart firefox. It should now work.

Modified by Steve3743