חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Japanese no longer displays on university webmail

  • 13 תגובות
  • 7 have this problem
  • 65 views
  • תגובה אחרונה מאת lisbet

more options

Just spent three hours trying to fix this with university IT- in most recent version of Firefox our university web email ( https://webmail.rice.edu/ ) cannot display Japanese correctly (It replaces it with ??????). No other websites are affected. We arrived at this conclusion after determining:

Safari still works fine with webmail Japanese Chrome also still works fine with webmail

We tested on 2 machines. A mac running an older version of Firefox displayed all webmail Japanese fine. It has no add-ons.

When we upgraded that machine's Firefox to newest version, it suddenly had problems displaying the Japanese.

My mac running current Firefox only started having problems displaying Japanese in webmail after installing current Firefox- even when I start in Safe mode.

I have tried every configuration for Character encoding that I can, with no luck.

Pasted below is only the info from MY mac. The other machine we tested on's info wouldn't add much, now that we've upgraded it to the current Firefox and thus broken webmail there too.

(As an aside, no settings in webmail have been altered. They are correctly set to have displayed Japanese prior to the last Firefox update.)

השתנתה ב־ על־ידי lisbet

כל התגובות (13)

more options

Does Japanese work on other websites in Firefox?

Did you check the encoding?

  • View > Character Encoding

Try to disable hardware acceleration.

  • Firefox > Preferences > Advanced > General > Browsing: "Use hardware acceleration when available"
more options

Yes, as I mentioned Japanese displays correctly on all sites except for my university webmail.

I have tried toggling the encoding every which way. On the other mac I experimented with, an older version of Firefox displayed everything correctly with encoding set to Unicode (UTF-8), but with the same settings this version of Firefox does not.

I tried the acceleration thing you suggested, but it didn't seem to change anything.

Unfortunately, this is a big problem for me, as I need to communicate in Japanese through my university email account for research. Argh.

more options

You can do a check for corrupted and duplicate fonts and other font issues:

more options

It's definitely not a font issue. On webmail from the login menu that you can see in my original link above, if I switch it to Japanese everything in Japanese displays correctly. But if I log in using English as I had always done, Japanese no longer works.

Japanese displays only as ??????? (question marks)

I Appreciate the help!

השתנתה ב־ על־ידי lisbet

more options

Works here:

Which font is used to display text with question marks?

more options

Oops, dupe posting

השתנתה ב־ על־ידי lisbet

more options

Yeah, all of my Japanese language email messages (and the names and subjects in my inbox view) display correctly when I switch webmail to all-Japanese, but then a bunch of my English language stuff just gets messed up. Argh! So, sadly, I can't just leave it in Japanese mode.

I installed that addon, and everywhere the question marks display in webmail is just Verdana.

more options

Do you get the correct text if you copy the text with the question marks to the clipboard and paste it elsewhere where it should work (e.g. in an editor)?

more options

No, it pastes as question marks as well, even if I do "Paste and Match Style" next to other Japanese text.

more options

That would indicate that the server is sending those question marks and that you do not get Japanese characters.

Did it ever work in Firefox 10 versions?

If not then there may be a problem with browser detection by that web server.

more options

I can't remember if it ever worked in Firefox 10, to be honest, but I'm guessing no.

I installed the User Agent Switcher add-on, set it up for a Firefox 9 profile, and followed the other directions on this page:

https://support.mozilla.org/en-US/kb/websites-incorrectly-report-firefox-outdated-or-in

(down to clearing my cookies and cache)

At first there was no change- I'd followed the directions to set my user agent to Firefox 9.0.1- but nothing changed until I randomly tried Internet Explorer 8 from among the add-on's default options.

THAT displayed my email properly, which was awesome.

השתנתה ב־ על־ידי lisbet

more options

Looks that the server indeed has a problem with your user agent.
Setting the user agent to IE is usually not a good idea because that can make the server send JavaScript that only works in IE and not in Firefox, so other things might not work.
You can try to contact the website another time and ask them to look into this.


Did you try a Firefox user agent for Windows (NT 6.0 or 6.1)?

  • Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
more options

I went to try that, but wasn't sure what to paste into the fields other than the User Agent field.

Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

What should the other fields be? (I noticed the add-on offers a list of possible agents to import, but none looked to be later versions of Firefox; perhaps I looked in the wrong place.)