חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 4 having trouble correctly displaying images on some websites

  • 4 תגובות
  • 12 have this problem
  • 3 views
  • תגובה אחרונה מאת Username.forum

more options

This problem started in the last few days. The JPEG thumbnails and in some cases larger JPEGs on certain websites is corrupted. Sometimes the whole image is looks very "blocky" and sometimes the first 10-30% of the image displays correctly and the rest is distorted and/or displays with weird colors.

I am using Firefox 4.0.1 on three different computers and it happens on all three! One computer is Windows 7 64-bit and the others are Windows XP SP3.

I have updated video drivers - no change. Two computers have Nvidia video, the third has some cheesy old integrated graphics.

The problem happens with Firefox in Safe Mode, and it happens (with both laptops) when I go to different WiFi hotspots.

It happens no matter how I set the color management.

I have cleared caches and cookies ... I have disabled my antivirus program ... no difference.

I have disabled hardware acceleration in Firefox - no difference.

Reloading the affected web page page does not change the problem. But I can copy the URL and paste it into IE9 and the page always displays correctly! Now, that should make you guys worry!

כל התגובות (4)

more options

Reset the page zoom on pages that cause problems: View > Zoom > Reset (Ctrl+0 (zero); Cmd+0 on Mac)

more options

Of course, page zoom is reset to 0 in safe mode, and I have the problem in safe mode, as stated in my original post. I tried the suggestion anyhow, and it doesn't make any difference.

more options

I'm having the same problem! I hope this gets fixed soon! I'm using Firefox 7.0.1 and been having this problem since upgrading to Firefox 4.

השתנתה ב־ על־ידי Username.forum

more options

Sometimes it is that corrupted, sometimes less corrupted, but usually not at all corrupted. I'm using Firefox 7.0.1 and been having this problem since upgrading to Firefox 4. Here are two images, which showed as corrupted. But later, atleast rebooted, but no Firefox or any other cache etc. cleaned, the first picture shows as it should be. The second picture still shows as corrupted, but when opening the second link when using private browsing, it shows as it should be. Here's example of corrupted image Another example of corrupted image from different website

השתנתה ב־ על־ידי Username.forum