חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF 3.6.4 seems to have major issues running Adobe Flash files

  • 15 תגובות
  • 21 have this problem
  • 12 views
  • תגובה אחרונה מאת cor-el

more options

When firefox automatically upgraded me to 3.6.4 a lot of the flash stuff I was working on stopped working. The flash files wouldn't even start up. They all worked fine on the previous version of firefox I had. I just downgraded to 3.5.9 and they work fine again. The flash also works fine on multiple versions of Safari, IE6,7,8, and chrome.

URL of affected sites

http://

כל התגובות (15)

more options

Your plugins list shows outdated plugin(s) with known security and stability risks.

# Next Generation Java Plug-in 1.6.0_17 for Mozilla browsers 

Update the Java plugin to the latest version. See http://java.sun.com/javase/downloads/index.jsp#jdk (you need JRE) --- Try to disable OOP (Out Of Process) for the Flash plugin. Set the pref dom.ipc.plugins.enabled.npswf32.dll to false on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the Enter key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.

more options

Cor-el thanking you for the fast reply, I appreciate it!

In order to start with a fresh slate, I did fresh installs of FF 3.6.4 on two of my other machines and installed the Flash plugin and tried my site and the flash didn't appear. I then changed the out of process bit to false as suggested and restarted both copies of firefox 3.6.4. Of the two flash swfs I had on my page one worked fine then (This one was a csutomized SlideShowPro for Flash) and the other one started to half-work. By this I mean before NOTHING came up and now the flash seems to load and the interface buttons come up on mouseover but no images appear. This swf is an Envato purchased banner rotator.

You can see them here:

http://www.scottsdaleeastof101.com/FHG_EVENTS/StPatricksDay.aspx

Thank you!

more options

I had the same problem and this solved it. It also solved another problem I was having where I was unable to save anything. I'd right click and click save as and NOTHING would happen. I couldn't select a folder to save to, it was like I was clicking air. I had tried all the resets suggested, but they didn't work. Doing this enabled my flash videos to work and now my saving option is working too. Thanks!

more options

Thanks, disabling "out of process" for npswf32.dll does solve a problem!

It's a kind of burden when user must remember to try to enable this option back in next releases until it runs smooth... :(

Once again, I'm grateful for clear advice!

more options
more options

Not a real fix.. just a step in the right direction.

I could not watch videos on Hulu, I tried the solutions in this thread, posted by cor-el, and I finally got a video to begin playing, however, I'm a skeptic, so I hit Back and tried clicking the same video again, and sure enough, it sat idle, then the Flash plugin crashed again. I did this a few times, and got the video to begin playing again, however the FPS and overall visual quality of the video and ads is horrendous. I'm running on a 1920x1200 resolution, and usually enjoy nice picture quality on Hulu, but the picture quality was pixelated/fuzzy, and the FPS was choppy (not running smoothly.)

I tried updating my JRE, JSE, Flash, Quicktime, and yes.. I followed that "The Adobe Flash plugin has crashed" guide, but all it does is increase the time my FF sits idle to 30seconds, up from 10. Then the plugin crashes again.

Need a real fix, not these little babystep solutions in the right direction. :P

more options

My problem is extremely similair except I am using Vista. Main issue is in FaceBook apps. It will sometimes work for a bit then crashes. Works fine in IE except extremely slow. How do u revert back to an older version of Firefox? when I go to the site, the new version is the only option I see.

more options

If you're still having issues with Firefox 3.6.4 and/or the Flash plugin, Firefox 3.6.6 has just been released to address this issue and increase the dom.ipc.plugins.timeoutSecs pref to 45 seconds if it has still the default value. Please see Update Firefox to the latest release if you need help updating.

more options

JYOuyang: "Out Of Process versus Flash" problem does persist in FF 3.6.6.

Brian: imho, the direction _is_ wrong. It takes much less than 45s to load under normal "in process" conditions.

It looks like roots of problem are deeper than supplied patches' layer. Some guard unconditionally blocks swf. Just my feeling..

more options

Does it help if you disable OOP ?

You can try to set all dom.ipc prefs to false to see if that helps. dom.ipc.plugins.enabled.npctrl.dll (Silverlight) dom.ipc.plugins.enabled.npqtplugin.dll (QuickTime) dom.ipc.plugins.enabled.npswf32.dll (Flash)

Make sure that your firewall allows the plugin-container.exe program full access to internet. It is a new program, so it is likely that your firewall doesn't recognize it.

more options

Yes, it helps both for 3.6.4 and 3.6.6. I deciphered dll names also.. :)

Firewall logs are clear and no prompts were seen but... I shell try tomorrow to investigate firewall behaviour more close. Child processes don't inherit FF rights, sure. And i didn't see any (by sysinternals' ProcExp). FF was not allowed to fork plugin-container.exe?

Thanks again, i'll relax rools &etc.! (It should be first step, i see, sorry...)

more options

Im sorry. Im a bit of a techno-tard and dont have any idea how to do these things. I reverted back to FF 3.5.10 and havent encountered this problem AS MUCH.

more options

You can try to set all dom.ipc prefs to false to see if that helps. dom.ipc.plugins.enabled.npctrl.dll (Silverlight) dom.ipc.plugins.enabled.npqtplugin.dll (QuickTime) dom.ipc.plugins.enabled.npswf32.dll (Flash)

To open the about:config page, type about:config in the location (address) bar and press the Enter key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page.

See also http://kb.mozillazine.org/about:config

more options

wth, firefox. I have the same problem, hulu won't play certain videos. no reason a major browser should have such an entry level problem on a major site. and yes, I updated to 3.6.6. Somebody fix it, please.

more options

correction: after the update NO video on hulu plays. Rather than wait for you to fix this I am downloading a rival browser. It's been fun, ff. It's not me it's you.