חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Increasing incompatibility with web sites I encounter

  • 11 תגובות
  • 0 have this problem
  • 69 views
  • תגובה אחרונה מאת blueline106

more options

More and more websites are alerting me that they are not fully compatible with Firefox and that I should instead use Chrome, Safari or Microsoft Edge. Recent examples are Allstate Insurance and Hewlett-Packard, not exactly insignificant players in the business world.

Here's what Allstate had across their page when I was attempting to log in:

"You may not be able to use certain My Account features on your current browser. For the best experience, consider using the latest versions of Chrome, Safari or Microsoft Edge."

There have been other websites with similar messaging about Firefox. The issue seems to be growing. Is there a fix coming from Firefox or are we going to continue to lose compatibility?

More and more websites are alerting me that they are not fully compatible with Firefox and that I should instead use Chrome, Safari or Microsoft Edge. Recent examples are Allstate Insurance and Hewlett-Packard, not exactly insignificant players in the business world. Here's what Allstate had across their page when I was attempting to log in: "You may not be able to use certain My Account features on your current browser. For the best experience, consider using the latest versions of Chrome, Safari or Microsoft Edge." There have been other websites with similar messaging about Firefox. The issue seems to be growing. Is there a fix coming from Firefox or are we going to continue to lose compatibility?
צילומי מסך מצורפים

כל התגובות (11)

more options

You can check for issues with Total Cookie Protection.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.

Helpful?

more options

Thanks for the response but this goes further than the same pat answers that I've seen elsewhere that neither address nor solve the problem. Besides, I don't see that this has anything to do with settings. I've been a Firefox user since the earliest days and have never encountered the kinds of banner and other automated responses I'm now getting from some websites.

To further clarify, I've also talked to several tech support specialists at a few companies over the past year or so and they tell me directly to use a browser other than Firefox for various reasons including diminished functionality, insufficient security, or other incompatibility issues.

This is an issue that Firefox needs to address. You're apparently being blackballed by websites at certain mainstream companies. Why, I don't know.

Helpful?

more options

If those FAQ aren't working then you need to provide the URL's so others can verify when they click on them in Firefox to see what if they see the same problem or not when going to those sites.

Helpful?

more options

One easy way for others to try would be to simply go to allstate.com and then enter a rogue login - just type in a few random letters in un and pw.

Resulting pw fail (or acceptance if you enter valid credentials) yields the browser banner warning for me. Maybe it will do the same for others?

By the way, the browser alert at Allstate will not be on every page - so far it's just initial page(s). That's another problem - the issues that I've encountered at other sites are random and may only affect a page here and there. It's not about the websites of companies, orgs, entities, etc. websites not loading at all.

What concerns me most are the responses I've gotten from a few tech assistance people I've talked to. They flat out say that Firefox is not a recommended browser due to incompatibility issues. A certain major financial institution along with a regional bank have told me the same thing. They have also mentioned the fact that while FF might work, features will go missing, hence their recommendations to use Chrome or Edge.

Helpful?

more options

I'm not seeing that banner, if I enter a random name and password then I get a page that the name an password aren't understood.

  • We are sorry but we are having difficulties understanding your request.

Did you at least tried my above suggestions as in a lot of cases this is caused by content blocking extensions or other changes made to the Firefox default settings ?

You can create a new profile as a quick test to see if your current profile is causing the problem. See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

more options

I'll have to work on this later as other duties call. Will work on it tomorrow when I have a bit of time and will let you know what transpires.

Meanwhile however, I've never seen a failed pw entry yield the kind of response you posted: "Difficulties understanding your request". What? See screenshot for what a failed pw entry at Allstate really looks like. To repeat, I've never seen a failed un/pw entry respond with a "not understood" reply.

And no one is addressing the comments I've been getting from tech support people. The first thing I'm often asked is what browser I'm using. The immediate answer is that their site is not compatible with FF. One of our major USA shippers has been adamant about that.

One last observation is that if default FF settings are causing these issues and if the screws are being turned that tight going in, then Mozilla needs to rethink that policy because your users are being summarily directed away from using Firefox.

Helpful?

more options

I suspect they must use certain features in those Browser to verify the user login access. As I see the same results so at this point you don't have a choice of Browser other then their recommended Browser to access the site.

השתנתה ב־ על־ידי Dropa

Helpful?

more options

That's what I was afraid of - website designers and engineers hiding behind security and other similar excuses to avoid doing a proper job. It's almost as though there's a conspiracy against FF by some websites and their designers/security chiefs. Maybe they are trying to lessen their workload and/or eliminate problem solving by focusing only on Chrome and Edge. If so, that's quite unfortunate and is a black eye on those involved in my opinion. How many everyday users see messages like that and just move on to another browser?

In the case of Allstate, I'm glad you can see the same thing I am seeing. Interestingly, I can log in to the site and it seems to work mostly ok. There may some functionality missing that I am not aware of, but as long as I can get in easily and get necessary tasks done quickly, I'm fine. Unfortunately, some of the other sites where I've encountered similar issues using FF are not always as forgiving.

I have been with Firefox since the very beginning and it remains my favorite browser, so I'll stick with it. It's an excellent browser and those who think otherwise are missing the boat. Maybe some of the incompatibilities get worked out in time.

Thanks for your reply and input. Likewise to cor-el for attempts to help. If either of you (or anyone else) has any input or thoughts, please post them here. I will experiment further with settings and other tweaks to see if any changes come about.

Helpful?

more options

I also have "We are sorry but we are having difficulties understanding your request", so can't reproduce.

But try to install this add-on and set Chrome or Edge UA for that website.

Helpful?

more options

@ cor-el

Yes I have attempted the fixes you linked several times recently and also have done so several times in the past. Maybe I've overlooked a step or am doing something wrong. I've also often tried disabling Enhanced Tracking on a per-site basis using the address box shield that I'm quite familiar with. I've also turned off ABP, to no avail.

I have not yet tried your suggestion of a new profile as a quick test. At some point I'll give that a shot, but for the moment there are too many other fires to put out so I'll use alt browsers for sites that don't behave in FF.

I do have another site from a major manufacturer with an issue. It's Larson Manufacturing/Larson Doors, a Fortune Brands company. Their customer Chat feature (a pop-up) is not working for me in FF. (It's fine in Chrome.) It should be easy for someone else to try so I'll furnish the url. And yes, I've disabled Enhanced Tracking Protection and ABP. Even with Enhanced Tracking turned on, it's telling me that no known trackers were detected on the page.

https://www.larsondoors.com/support/chat-with-us#

The chat feature button is near the bottom of the page on the right side. I will say that the Larson webpage looks ancient and poorly configured. Possibly no one is correcting problems or keeping it updated - there are many poorly configured websites, many more than I've seen in years past. But if that's the case, why do they work fine using Chrome?

I am curious as to what you (or any others who attempt to start a chat using this link) find out. Relatively recent chats at other sites have worked fine with FF so this may be a Larson website issue.

Helpful?

more options

I did a complete deletion and re-installation of Firefox. No changes whatsoever to the issues of lost functionality at some websites. It's pretty obvious that an increasing number of sites are simply not being configured nor optimized for Firefox and Firefox is apparently doing nothing to remedy the issues.

No comments on the Larson Manufacturing chat glitch?

I tried Allstate's login page again and got the same message. No one has commented on the obvious Allstate splash screen stating in plain English to use another browser, specifically listing Edge, Chrome, and Safari. That little giveaway is being ignored on this thread and elsewhere. Why, I don't know, unless FF is giving up the ghost.

As I've said repeatedly, tech support personnel at a growing number of business and other organization are specifically telling users to use a browser other than Firefox. Is anyone directly connected with FF seeing any of this? Does anyone even care anymore?

השתנתה ב־ על־ידי blueline106

Helpful?

פרסום שאלה

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.