חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop Firefox from changing http to https?

  • 10 תגובות
  • 1 has this problem
  • 44 views
  • תגובה אחרונה מאת cor-el

more options

Yes. "Don’t enable HTTPS-Only Mode" is checked. Yes. In about:config "browser.urlbar.autoFill" is set to false. It STILL does it! This is maddening. I'm trying to go to an address on my network for my IP cameras. http://192.168.50.65 (for example), and Firefox keeps changing it https! Then of course, it won't connect. How do I stop this? I hate having to start Chrome or Opera to manage these local addresses.

Yes. "Don’t enable HTTPS-Only Mode" is checked. Yes. In about:config "browser.urlbar.autoFill" is set to false. It STILL does it! This is maddening. I'm trying to go to an address on my network for my IP cameras. http://192.168.50.65 (for example), and Firefox keeps changing it https! Then of course, it won't connect. How do I stop this? I hate having to start Chrome or Opera to manage these local addresses.

כל התגובות (10)

more options

What kinda site is that. Sites use https to secure user login and you can't stop that.

Helpful?

more options

Like I said, it is a local address for my IP cameras (home security) to configure the camera. It does the same thing when I try to access the router by name. http://router.asus.com is changed to https://router.asus.com, then I can't get to the router configuration.

Helpful?

more options

Sounds like router issues did you check with the router support?

Helpful?

more options

Can't you disable HTTPS-Only for this website via the padlock or add an exception directly ?

See Turn off HTTPS-Only Mode for certain sites:

This can possibly happen if asus.com is on the HSTS preload list. You can try to edit the SiteSecurityServiceState.txt file in the Firefox profile folder and remove the line from this particular domain, to see if that allows to add an exception.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

more options

A router issue LOL! Firefox literally changes http to https in the address bar. The router must be really hostile to Firefox to do that only to Firefox and not to Chrome or Opera.

Helpful?

more options

nosoy1 said

It does the same thing when I try to access the router by name. http://router.asus.com is changed to https://router.asus.com, then I can't get to the router configuration.

You should still be able to access your ASUS router by the IP address as the common one is 192.168.1.1

Helpful?

more options

Dropa said

Sounds like router issues did you check with the router support?

It is not a router issue.

Helpful?

more options

router.asus.com is not a public site. It is the local router configuration. Removing lines from that security text file had no effect. HTTP-Only-mode is already disabled in the the settings. Firefox is literally changing text http to https in the address bar after I type it in. How do stop it from changing what I type in?

Helpful?

more options

Are you using a private windows? In addition to the "HTTPS Only" feature, private windows have an "HTTPS First" feature that can cause this problem. More details if relevant.

[EDIT: I see cor-el already covered this one:] The other reason Firefox might upgrade to HTTPS is if the server previously instructed it to do so via an HTTP Strict Transport Security (HSTS) header. Usually the error page will tell you if that is the case. If your error page says that, then we can help you clear out that information and see whether that helps.

השתנתה ב־ על־ידי jscher2000 - Support Volunteer

Helpful?

more options

It looks like the devs added a quick fix to Firefox 105, to be released this Tuesday, and have removed asus.com from the HSTS preload list, so you can give it a try tomorrow to see if updating to 105 works for you. You may have to clear cache and cookies for asus.com and possibly check SiteSecurityServiceState.txt in the profile folder or use "Forget About This Site".


(please do not comment in bug reports
https://https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Helpful?

פרסום שאלה

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.