חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Refresh or Shift Refresh doesn't reload the page

  • 7 תגובות
  • 1 has this problem
  • 777 views
  • תגובה אחרונה מאת César Matelat

more options

I am a HTML, PHP developer, but lately I am going crazy because the browser doesn't refresh the page when I make changes in the code, apparently the page is refreshed from cache and is not showing the changes. Could You fix that Please. I tried the recommendations of press Shift and the refresh button and the Control, Shift, R, key combination, but that doesn't work. Thank You Very Much.

I am a HTML, PHP developer, but lately I am going crazy because the browser doesn't refresh the page when I make changes in the code, apparently the page is refreshed from cache and is not showing the changes. Could You fix that Please. I tried the recommendations of press Shift and the refresh button and the Control, Shift, R, key combination, but that doesn't work. Thank You Very Much.

פתרון נבחר

I found the problem, in the php.ini file, the value for: opcache.enable has to be zero: opcache.enable=0 Thanks for your time and I hope this helps someone else.

Read this answer in context 👍 0

כל התגובות (7)

more options

Hi César, these should bypass the cache:

  • Ctrl+Shift+R
  • Shift+click the Reload button
  • Ctrl+F5

That normally works for your main page, images, and JavaScript files, but some files are cached more tenaciously, such as CSS files. You may need to open the Network Monitor (Ctrl+Shift+E) and check the Disable Cache box. More info on this tool: https://developer.mozilla.org/docs/Tools/Network_Monitor

more options

Hi Jscher2000, Thank You for your contribution, but that doesn't work, did You try to reproduce the problem?. I need to clarify that the problem is always with PHP scripts, I tried plain HTML and the refresh button alone, works instantly, but with PHP scripts, even with the toolbox open and the HTTP Cache dissabled, it always fail, even pressing Shift and the refresh button, Control, Shift, R or Control F5. I hope anybody can helpme fix that problem. Thanks.

more options

Hi César, the way I edit PHP files is to edit locally on disk and then FTP the updated file to my website for previewing, since I don't have an editor that can preview PHP files directly on my system. Is that your process as well, or do you have a local preview facility or do you use an online editor?

more options

I use XAMPP server to locally develop and test the sites. I looked for other solutions like forcing the script to no caching the pages: ' header('Expires: Sun, 01 Jan 2014 00:00:00 GMT'); header('Cache-Control: no-store, no-cache, must-revalidate'); header('Cache-Control: post-check=0, pre-check=0', FALSE); header('Pragma: no-cache'); ?>' But it still doesn't work.

השתנתה ב־ על־ידי César Matelat

more options

Usually cache-control: no-store would be all you need.

Is it working as expected in other browsers on your system, for example, Microsoft Edge?

more options

Also, if you modify the URL, do you get the freshly generated page? For example, depending on your URL:

  • https://myhost/index.php => https://myhost/index.php?1
  • https://myhost/index.php?q=test => https://myhost/index.php?q=test&1
more options

פתרון נבחר

I found the problem, in the php.ini file, the value for: opcache.enable has to be zero: opcache.enable=0 Thanks for your time and I hope this helps someone else.