חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How Do You Stop New Links/Tabs Stacking On Top of Each Other in one 'pile' on far left above address bar?

  • 50 תגובות
  • 1 has this problem
  • 195 views
  • תגובה אחרונה מאת StevenB

more options

Whenever I open a new link/website tab FF stacks each site (tab, that is) on top of each other rather than having all the tabs displayed across the top. I want to have all NEW website tabs not stacked on top of each other. Presently, I have to 'X' out of each open tab that is in a stack to get to the one buried to the one I want below. I also do not want to hover over the FF icon on taskbar to display all open windows/tabs (that I can barely make out) to try to find what I am looking for .

I can't get each new link/tab to open next to the one to the left. I want the tabs to look like first photo. All the tabs -websites are stacked on top of each other to the far right (second photo). I want my FF pages/tabs to properly look like the first screen shot on left (this shot is from my laptop....issue is with desktop computer), and not the screen shot on right that shows one tab/windows but has several more websites/tabs under it.

I do not have any tab extensions installed and all my tab options are unchecked in Options. I think this issue is somewhere in the preferences (about:config). No clue where..

Also, is there a way to have all newly open tabs open first on the far LEFT rather the far right.

Thank you in advance.

Steven

צילומי מסך מצורפים

השתנתה ב־ על־ידי StevenB

פתרון נבחר

McCoy said

You've got to be kidding ! That same preference is in your own thread that I linked to yesterday : https://support.mozilla.org/en-US/questions/1275305 And here I was, searching some more trying to find what could possibly be causing this (thinking you'd be sound asleep); wanted to carefully go over your thread again and : BAM  ! you had just solved the problem all by yourself ! The fact that you mentioned "clicking on bookmark links" could have (should have) been a clue ...... Well done you ! Please mark your own last post as Chosen Solution ("Solved the problem" button to the right), so everyone will know. Great job, Steven !

Whatever it is/was, it's fixed. Sure would like to know how it happened since I just upgraded my system to Win 10 Pro from Win 7 and reinstalled ALL my software programs as if this was a new machine. Not that important now. Thank you ...for all your help! Dodge the virus germs and stay at home! Steven

Read this answer in context 👍 0

כל התגובות (20)

more options

McCoy said

StevenB said
Hey, thanks so much!!!...stay safe!

I wish I could have helped - I was sooo convinced that you were opening windows instead of tabs (just being a stubborn girl).

As for staying safe : you too ! (over here we're not supposed to leave the house)

No worries, I hope someone can help me out. It's exasperating. When I open a new URL while another URL tab is open, as an example, the new URL tab flashes open very quickly to the right of the already opened one then recedes/tucks back/stacks on top of the already open one. If you get this.

I'm in L.A. and the whole state is quarantined...I'm so bored! :-)

more options

StevenB said

When I open a new URL while another URL tab is open, as an example, the new URL tab flashes open very quickly to the right of the already opened one then recedes/tucks back/stacks on top of the already open one. If you get this.

Stephen King would love this .....

I'm in L.A. and the whole state is quarantined...

Same here (in The Netherlands, Europe)

more options

McCoy said

StevenB said
When I open a new URL while another URL tab is open, as an example, the new URL tab flashes open very quickly to the right of the already opened one then recedes/tucks back/stacks on top of the already open one. If you get this.

Stephen King would love this .....

I'm in L.A. and the whole state is quarantined...

Same here (in The Netherlands, Europe)

spot-on!
more options

Hi StevenB, could you turn on the "List All Tabs" button:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste tabman and pause while the list is filtered

(3) Double-click the browser.tabs.tabmanager.enabled preference to switch the value from false to true

That should add a little button to the right side of the tab bar which shows all the tabs in the current window:

Does the list show any non-visible tabs?

more options

^ I just tried it - after changing the value I had to close and restart Firefox.

Worked like a charm !

more options

StevenB said

When I open a new URL while another URL tab is open, as an example, the new URL tab flashes open very quickly to the right of the already opened one then recedes/tucks back/stacks on top of the already open one. If you get this.

Hmm, it would be a bizarre irony if you somehow installed my "I Hate Tabs" add-on which does pretty much exactly that: it detects the new tabs opened in a window and pops them out into their own separate windows.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions tabs, looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove).

Any change?

more options

jscher2000 said

Hi StevenB, could you turn on the "List All Tabs" button: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste tabman and pause while the list is filtered (3) Double-click the browser.tabs.tabmanager.enabled preference to switch the value from false to true That should add a little button to the right side of the tab bar which shows all the tabs in the current window: Does the list show any non-visible tabs?

No. Here are screen shots-- nothing hidden . I deleted disabled extensions that had anything to do with tabs.

BTW, I have a Windows 10 pro, not a mac.

Scroll up a bit and you will see a screen shot of my laptop which is what I am trying to have my desktop computer function like. My FF is synched on both laptop and desktop computers.

Still have the same issue after a reinstall that I did last week when trying to fix another FF issue.

PLEASE, any idea fixes or causes why ALL each unique websites' tab stacks on top of each other when it should look like my laptop screenshot above.? This is frustrating.

Thanks!

more options

McCoy said

^ I just tried it - after changing the value I had to close and restart Firefox. Worked like a charm !


what worked like charm? Not sure what you are referring to?

more options

This is likely about having the "List all tabs" button always visible.

In the "Lit all tabs" button drop-down list you can see the number of tabs opened in the current window and the first screenshot shows that only that Google tab is present.

You can make the top window smaller (unmaximize and drag it lower) to reveal other windows hidden by the top window.

You can also use Alt+Tab to cycle through all open windows.

more options

cor-el said

This is likely about having the "List all tabs" button always visible. In the "Lit all tabs" button drop-down list you can see the number of tabs opened in the current window and the first screenshot shows that only that Google tab is present. You can make the top window smaller (unmaximize and drag it lower) to reveal other windows hidden by the top window. You can also use Alt+Tab to cycle through all open windows.

I have no idea what is or where you are referring ""List all tabs" button drop-down list you can see the number of tabs opened in the current window and the first screenshot shows that only that Google tab is present." Not sure what this might have to do with my issue. I simply want my tabs to open like you see in the screen shot (from laptop) on me desktop computer below. I do not want URL tabs all stacked on top of each other. There is something going on causing every website tab to stack on top of each other in far right. If you were to 'X' out of the top one, then you would see the next one opened next, and so on. This is painfully simple issue I am explaining.

Thanks!

more options

StevenB said

what worked like charm? Not sure what you are referring to?

Oh, just to get that little arrow ("List All Tabs" button), click on it and see all open tabs.

Did not explain why all of your tabs are stacked; if it had, "worked like a charm" would have been an understatement.

It would have been so great if you had that "I Hate Tabs" extension installed (active), and that it turned out to be the culprit, but you disabled all extensions ...... right ?

more options

McCoy said

StevenB said
what worked like charm? Not sure what you are referring to?

Oh, just to get that little arrow ("List All Tabs" button), click on it and see all open tabs.

Did not explain why all of your tabs are stacked; if it had, "worked like a charm" would have been an understatement.

It would have been so great if you had that "I Hate Tabs" extension installed (active), and that it turned out to be the culprit, but you disabled all extensions ...... right ?

Actually, I deleted all TAB related extensions....did nothing. I had to reinstall FF last week for another issue and this issue still lingered. This is some kind about:config issue of some kind...I'm sure it is.

more options

StevenB said

This is some kind about:config issue of some kind...I'm sure it is.

And of course you don't remember which prefs you toggled ?

You could go to the "about:config" page; type in the search bar tabs, look at what is listed there and see if any of them rings a bell.

Worth a try .....

more options

I just looked at your earlier (tabs related) threads :

https://support.mozilla.org/en-US/questions/1268799

https://support.mozilla.org/en-US/questions/1275305

I don't think that any of those preferences you may have toggled could cause this "Stephen King"-like phenomenon, but who knows .....

more options

McCoy said

StevenB said
This is some kind about:config issue of some kind...I'm sure it is.

And of course you don't remember which prefs you toggled ?

No I don't.

You could go to the "about:config" page; type in the search bar tabs, look at what is listed there and see if any of them rings a bell.

Worth a try .....

I wouldn't know what to even look for or what would be wrong to look for.

more options

McCoy said

I just looked at your earlier (tabs related) threads : https://support.mozilla.org/en-US/questions/1268799 https://support.mozilla.org/en-US/questions/1275305 I don't think that any of those preferences you may have toggled could cause this "Stephen King"-like phenomenon, but who knows .....

this is not a toggle/pref issue. It's some kind of about:config matter. I'm not that deeply knowledgeable about the commands in there. Need a manual ! :-)

more options

StevenB said

I wouldn't know what to even look for or what would be wrong to look for.

Quite frankly : I already did look last night (my time), but didn't see any pref that could possibly be causing this.

But as you are so sure that it must be a pref .....

No bells ringing at all ?


Well, let's just hope that someone will come up with a brilliant idea.

There must be a solution !

more options

StevenB said

this is not a toggle/pref issue. It's some kind of about:config matter.

Oh boy .....

When you said earlier that you are sure that it is an "about:config" issue, I thought you knew what changing the value of a preference on the "about:config" page means.

I hope this will help :

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

more options

McCoy said

StevenB said
I wouldn't know what to even look for or what would be wrong to look for.

Quite frankly : I already did look last night (my time), but didn't see any pref that could possibly be causing this.

But as you are so sure that it must be a pref .....

No bells ringing at all ?


Well, let's just hope that someone will come up with a brilliant idea.

There must be a solution !

Thanks for taking the effort and time to look for me. Very grateful.  I know there is a solution.  Somebody out in FF land must know. I should drive up to San Fran from L.A. and knock on their door and ask someone since they don't have phones.  I might repost this and see if some FF wizard knows.  It's such simple issue.  Thanks, Steven

השתנתה ב־ על־ידי StevenB

more options

StevenB said

McCoy said
StevenB said
I wouldn't know what to even look for or what would be wrong to look for.

Quite frankly : I already did look last night (my time), but didn't see any pref that could possibly be causing this.

But as you are so sure that it must be a pref .....

No bells ringing at all ?


Well, let's just hope that someone will come up with a brilliant idea.

There must be a solution !

Thanks for taking the effort and time to look for me. Very grateful.  I know there is a solution.  Somebody out in FF land must know. I should drive up to San Fran from L.A. and knock on their door and ask someone since they don't have phones.  I might repost this and see if some FF wizard knows.  It's such simple issue.  Thanks, Steven
  1. 1
  2. 2
  3. 3