X
Tap here to go to the mobile version of the site.

Support Forum

Cookies are not stored

Posted

Whenever i restarted my computer and launch Firefox, i have to accept all the cookies from websites again. Also on some webpages i have to go through a tutorial again and again. these informations were stored before firefox 57 and i klicked all of these once and never again. i already cleared the cache and even reinstalled firefox and deleted my profile. nothing helped so far.

Whenever i restarted my computer and launch Firefox, i have to accept all the cookies from websites again. Also on some webpages i have to go through a tutorial again and again. these informations were stored before firefox 57 and i klicked all of these once and never again. i already cleared the cache and even reinstalled firefox and deleted my profile. nothing helped so far.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Question owner

Here an example

Here an example
FredMcD
  • Top 10 Contributor
4269 solutions 59845 answers

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

Question owner

Never changed any software, just updated firefox. Running Win 10 with onboard security (defender).

Already deleted profile folder and uninstalled/reinstalled firefox. did a sync after that. same problem still exists. can the fault be copied from sync?

Never changed any software, just updated firefox. Running Win 10 with onboard security (defender). Already deleted profile folder and uninstalled/reinstalled firefox. did a sync after that. same problem still exists. can the fault be copied from sync?
FredMcD
  • Top 10 Contributor
4269 solutions 59845 answers

Icewolf77 said

Never changed any software

Software changes over time via updates. Sometimes an update breaks something.

can the fault be copied from sync?

That is possible, depending on the cause of the problem.

''Icewolf77 [[#answer-1061499|said]]'' <blockquote> Never changed any software </blockquote> Software changes over time via updates. Sometimes an update breaks something. <blockquote> can the fault be copied from sync? </blockquote> That is possible, depending on the cause of the problem.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

If clearing cookies didn't help then It is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted. *rename/remove <b>cookies.sqlite</b> (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Didn't help. Like i said, i already deleted the whole profile folder and did a re-install with a sync. Didn't change anything.

Didn't help. Like i said, i already deleted the whole profile folder and did a re-install with a sync. Didn't change anything.
Shadow110 1072 solutions 14836 answers

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 57.0.4 with a Full Version Installer

Also try creating a new Profile and make it active and try with nothing in it.

Please let us know if this solved your issue or if need further assistance.

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.4 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Also try creating a new Profile and make it active and try with nothing in it. *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles Please let us know if this solved your issue or if need further assistance.
FredMcD
  • Top 10 Contributor
4269 solutions 59845 answers

Icewolf77 said

Like i said, i already deleted the whole profile folder and did a re-install with a sync. Didn't change anything.

It's possible that something being synced is the problem. Create a new, clean profile. Do Not use sync. Any problems?

''Icewolf77 [[#answer-1063694|said]]'' <blockquote> Like i said, i already deleted the whole profile folder and did a re-install with a sync. Didn't change anything. </blockquote> It's possible that something being synced is the problem. Create a new, clean profile. '''Do Not''' use sync. Any problems?