חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is it no longer safe to use Firefox on a mac. seeing your doing no updates

more options

Just updated to 48 and told no more updates

פתרון נבחר

It will be secure for a while yet if ESR is used next. If you are unable to upgrade OS x any further have you considered switching to a Linux OS, possibly as a dual boot installation.

That would allow you to use OSX for its features when offline but boot in to Linux when you needed to securely use the internet with Firefox. That is a topic outside the scope of this forum. But you could search the internet with Firefox for such solutions, For example

Note there are many versions of Linux, some with lower System Requirements than a standard Ubuntu, There is even the posibiity of running Linux off thumb drives. Most Linux software is free.

Read this answer in context 👍 1

כל התגובות (10)

more options

peacefieldsretreat said

Just updated to 48 and told no more updates

Firefox 48.0 was only just released yesterday Aug 2nd. https://www.mozilla.org/firefox/48.0/releasenotes/

Oh I take it you got a message saying Firefox 48.0 will be the last supported for your old Mac OSX 10.7

See https://support.mozilla.org/en-US/kb/firefox-osx

Firefox 49.0 and newer Releases will require OSX 10.9 or newer. There is a option of using the Firefox 45 ESR branch to get security updates for a while still as 45.8.0esr will be out when Firefox 53.0 is released.

השתנתה ב־ על־ידי James

more options

New versions of Firefox will require OSX 10.9 or later. Please see this article for more information:

https://blog.mozilla.org/futurereleases/2016/04/29/update-on-firefox-support-for-os-x/

more options

jscher2000 said

New versions of Firefox will require OSX 10.9 or later. Please see this article for more information: https://blog.mozilla.org/futurereleases/2016/04/29/update-on-firefox-support-for-os-x/

That old blog post is a bit misleading as some might think support for OSX 10.6, 10.7, 10.8 has ended now as I think it originally was going to be for Fx 48.0 and not FX 49.0

השתנתה ב־ על־ידי James

more options

This is all great but if you want to use Firefox in future and have an older Mac that can't use the latest OS systems . You will need a new Mac. David

more options

peacefieldsretreat said

This is all great but if you want to use Firefox in future and have an older Mac that can't use the latest OS systems . You will need a new Mac. David

You can still use the Firefox 45 esr branch to get security updates for Firefox for a while as I said. However yes you will need OSX 10.9 or newer if you want to use new Releases as in 49.0 and newer.

more options

Thanks for that, but I work for a not for 'profit organisation' ,with limited funds and their must be thousands of people across the world who are in a similar position to me. I always thought Firefox was for all the community and not a sales organisation for Mac. I guess we will have to stop using Firefox for our browser. We use Lion OS 10.7.5 which isn't that old, David

more options

Keep in mind that you probably can just update your mac to the latest version of Mac OS for free, https://support.apple.com/en-us/HT201475


I would strongly suggest this as the version of Mac you are running now is no longer supported by apple and is insecure.

more options

No I am sorry Tyler you cannot do this as the computer will not allow this. The system I am running is supported by Mac. at the moment.

more options

פתרון נבחר

It will be secure for a while yet if ESR is used next. If you are unable to upgrade OS x any further have you considered switching to a Linux OS, possibly as a dual boot installation.

That would allow you to use OSX for its features when offline but boot in to Linux when you needed to securely use the internet with Firefox. That is a topic outside the scope of this forum. But you could search the internet with Firefox for such solutions, For example

Note there are many versions of Linux, some with lower System Requirements than a standard Ubuntu, There is even the posibiity of running Linux off thumb drives. Most Linux software is free.

השתנתה ב־ על־ידי John99

more options

.thank you all for your help David