Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't let me go to facebook also just installewdthe new kaspersky what do I do to fix this

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by jscher2000

more options

facebook & youtube what is wrong

All Replies (2)

more options

Do you get messages that Firefox cannot create a secure connection to those sites? That's actually normal with Kaspersky because it intercepts your browsing connections for filtering. With secure sites, it needs to present a fake certificate to Firefox in order to decrypt and read the transmission.

If you are willing to live without that feature:

Check out the steps in this article: How to troubleshoot security error codes on secure websites

If you want Firefox to work with this feature:

You may need to manually import the Kaspersky signing certificate into Firefox, or maybe Kaspersky will handle it when you shut down and restart Windows.

To do it by hand:

Open Firefox's Certificate Manager:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced

On the right side, make sure the Certificates mini-tab is selected and then click the View Certificates button

In the Certificate Manager dialog, click the "Authorities" mini-tab (not the Servers mini-tab)

If you see an existing "Kaspersky Anti-Virus Personal Root Certificate"

Select it and Click "Delete or Distrust"

Now click "Import..."

Proceed to "C:\ProgramData\Kaspersky Lab\AVP16.0.0\Data\Cert\"

Select "(fake)Kaspersky Anti-Virus Personal Root Certificate.cer" and Open!

Set Firefox to trust that certificate for websites, and ignore the other two options.

Then you can test various secure sites to see whether Firefox now trusts the fake certificates. If it doesn't work right away, exit out of Firefox and start it up again.

Modified by jscher2000

more options

Actually, another user said you have to exit Firefox and start it up again after making this change. I will add that to my previous post for future reference..