Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I keep spellchecker from resetting language?

  • 4 replies
  • 1 has this problem
  • 16 views
  • Last reply by cor-el

more options

I have Ubuntu 12 and the latest version of Firefox for it. spellcheck.dictionary keeps getting reset to en_GB How do I force it to stay en_US? Lots of people having this issue, and the responses are all a bunch of head-scratching. There has to be a way to make Firefox stop arbitrarily changing this setting.

All Replies (4)

more options

I've called the big guys to help you. Good luck.

What spell checkes do you currently have on your Firefox?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

"What spell checkes do you currently have on your Firefox?"

Whatever comes with it.

more options

Please check out; How do I use the Firefox spell checker? https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

more options

Ubuntu may be adding a lot of spell checking dictionaries that are all detected by Firefox. These dictionaries use an underscore (en_US) as a separator and not a dash that Firefox uses for a dictionary (en-US) that you install via the Add-ons website or that come with the Firefox installer.

You can check these locations for globally installed dictionaries:

/usr/share/hunspell/
/usr/share/myspell/