Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Re-installed linux; Firefox doesn't use my old profile.

  • 2 replies
  • 1 has this problem
  • 75 views
  • Last reply by Michael K.

more options

I had to reinstall my OS (linuxmint - debian edition - 201403). I left /home intact. After the process, I checked the profile -- nothing was changed. So I ran Firefox. But, my bookmarks didn't load (only the few that come with a new install). It didn't load the preferences either. I tried some tricks to get it to load my profile (i.e. create a new profile and copy the contents, Help>Troubleshooting Information -- Reset). Still no joy. I even tried running in a shell with -P <profile> for both the original and new profiles. Still no bookmarks (or anything from my original profile).

Also, on the Help>Troubleshooting Information page, I click 'open directory' and see my original profile.

What's wrong, and how do I fix it?

Modified by Michael K.

Chosen solution

Ok, I figured it out. I had Firefox running (to check how to work with profiles). I quit the program, then copied the old profile. Well, I tried copying on a freshly-booted machine -- it worked!

Read this answer in context 👍 0

All Replies (2)

more options
more options

Chosen Solution

Ok, I figured it out. I had Firefox running (to check how to work with profiles). I quit the program, then copied the old profile. Well, I tried copying on a freshly-booted machine -- it worked!