חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube (https)security certificate issue

  • 25 תגובות
  • 45 have this problem
  • 1195 views
  • תגובה אחרונה מאת reyligh

more options

Hi

I'm using latest firefox version with and recently I'm facing this strange issue ... everytime I try to visit youtube, to be specific, when not logged in on any google accounts .. I can visit http://www.youtube.com but when I try to login, in which case it redirects to https:// and It shows the following error(check image url):

https://imageshack.com/i/ezbe0c53j

And if I try to add exception, it shows this screen(check image url):

https://imageshack.com/i/hj41802cj

(PS: Couldn't find upload option here so I had to use otherimage hosts)

Also I tried changing windows time, adding auto time sync from windows site and also tried changing profile, disabling add on and testing and also tried removing cache/cookies from both google.com and youtube.com and so far nothing worked ... I can't seem to access youtube while logged in (https)

Also its only youtube, no other website shows this security certificate error!

please provide a solution to this asap, thanks!

Hi I'm using latest firefox version with and recently I'm facing this strange issue ... everytime I try to visit youtube, to be specific, when not logged in on any google accounts .. I can visit http://www.youtube.com but when I try to login, in which case it redirects to https:// and It shows the following error(check image url): https://imageshack.com/i/ezbe0c53j And if I try to add exception, it shows this screen(check image url): https://imageshack.com/i/hj41802cj (PS: Couldn't find upload option here so I had to use otherimage hosts) Also I tried changing windows time, adding auto time sync from windows site and also tried changing profile, disabling add on and testing and also tried removing cache/cookies from both google.com and youtube.com and so far nothing worked ... I can't seem to access youtube while logged in (https) Also its only youtube, no other website shows this security certificate error! please provide a solution to this asap, thanks!

פתרון נבחר

finally i figured out the issue, it seems like i had a IP redirection setup at windows>hosts file for youtube a while back when youtube was blocked by the gov here.

so i removed it and everything seems to be working fine.

Read this answer in context 👍 5

כל התגובות (5)

more options

i tried safe mode/restart with addons disabled and still shows same certificate error ... im totally lost here.

more options

also i checked ... the following:

""3-bar" menu button (or Tools menu) > Options > Advanced > Network mini-tab > "Settings" button

The default is "Use system proxy settings" but you also could try "No Proxy". "

and its exactly as it should be ... its using the "Use system proxy settings" and also tried disabling anti-virus (avast free edition) ... and still shows same error.

I'm just not getting why it would be showing this error ...

more options

btw i just tested with chrome and safari and explorer and all browsers show the same error ... im not tech guru but with this test i can only assume its not really firefox(probably)

could you guys give me an idea what could be interfering with the connection settings ...

i mean by the looks of things and the comments and my google research i can only assume somehow im not getting the right security certificate ... or atleast all my browsers are thinking its not correct ...

what could be causing this issue? i mean what are the possible reasons ....

more options

Since Firefox uses its own certificate store, and Chrome uses IE's certificate store, I agree this doesn't sound like an issue specific to one browser or one certificate store.

Do you want to try changing your DNS service to Google Public DNS? I can't say for sure that isn't tracked by Google, but I'm pretty sure it should be accurate for YouTube. If this works, it would indicate a problem with your current DNS service.

https://developers.google.com/speed/public-dns/docs/using

more options

פתרון נבחר

finally i figured out the issue, it seems like i had a IP redirection setup at windows>hosts file for youtube a while back when youtube was blocked by the gov here.

so i removed it and everything seems to be working fine.

  1. 1
  2. 2