Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wannan tattunawa ta zama daɗaɗɗiya. Yi sabuwar tambaya idan ka na bukatar taimako.

Addon for tif and tiff reinstalled. Will not open files

  • 7 amsoshi
  • 1 yana da wannan matsala
  • 85 views
  • Amsa ta ƙarshe daga D_Hailsham

more options

The add on was reinstalled yesterday, with help from this forum, thanks.

It is listed OK in the add ons and is listed as handling image/tif and image/tiff files. However in Tools/Options/Applications it shows:

1. TIFF image (application/tif) - Always Ask

2. TIFF image (image/tiff) - Use Grafixview Netscape plugin (in Firefox)

How do I make the Grafixview plugin handle image/tif files? It is not listed as an option when I try to change the "Always ask".

The add on was reinstalled yesterday, with help from this forum, thanks. It is listed OK in the add ons and is listed as handling image/tif and image/tiff files. However in Tools/Options/Applications it shows: 1. TIFF image (application/tif) - Always Ask 2. TIFF image (image/tiff) - Use Grafixview Netscape plugin (in Firefox) How do I make the Grafixview plugin handle image/tif files? It is not listed as an option when I try to change the "Always ask".

An gyara daga D_Hailsham

Mafitar da aka zaɓa

As you add and remove plugins and open downloads, Firefox accumulates information in a file named mimeTypes.rdf. This file also is used to record changes you make in the Options > Applications list. Unfortunately, this file sometimes can't be fixed through the user interface and because its layout is somewhat inscrutable, it's also difficult to edit.

I suggest renaming the file and letting Firefox generate a new one. Hopefully this will resolve the QuickTime confusion and perhaps clean up the difference between application/tif and image/tif.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox and check the Options > Applications tab for any changes/improvements.

If the cure is worse than the disease, you can reverse the process by deleting the newly generated mimeTypes.rdf and renaming the earlier file back to that name.

Karanta wannan amsa a matsayinta 👍 1

All Replies (7)

more options

(Earlier thread: I cannot reinstall the GrafixView add-on.)

I gather you're saying that when you open a new tab to about:plugins and look at the content types listed under GrafixView, image/tif is there as expected. But it doesn't work?

more options
more options

Unfortunately the Alternatiff plugin does not work correctly on the website I need to visit. The site states that I need the Grafixview plugin to display the graphics.

more options

I've never used the about:plugins route before, but you are correct.

If you use the route I gave, via the menus - Tools/Options/Applications you see this:

1. TIFF image (application/tif) - Always Ask

2. TIFF image (image/tiff) - Use Grafixview Netscape plugin (in Firefox)

Why is a TIF file listed as an application while the TIFF is show as an image?

How do I get Grafixview to open the TIF file?

Incidentally, when I go to the web site which needs this plugin the graphics are opened by QuickTime, even though the Quicktime plugin is disabled.

The problem with using Quicktime is that it doesn't not allow me to scroll or zoom the graphics.

I have check using about:plugins and the only one listed for TIF and TIFF files is the Grafixview. So why is Quicktime opening them?

more options

Zaɓi Mafita

As you add and remove plugins and open downloads, Firefox accumulates information in a file named mimeTypes.rdf. This file also is used to record changes you make in the Options > Applications list. Unfortunately, this file sometimes can't be fixed through the user interface and because its layout is somewhat inscrutable, it's also difficult to edit.

I suggest renaming the file and letting Firefox generate a new one. Hopefully this will resolve the QuickTime confusion and perhaps clean up the difference between application/tif and image/tif.

Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox and check the Options > Applications tab for any changes/improvements.

If the cure is worse than the disease, you can reverse the process by deleting the newly generated mimeTypes.rdf and renaming the earlier file back to that name.

more options

That did the trick, thanks!

When I now look in Applications it shows only one entry for TIFF with the Grafixview plugin given as "Action"

more options

Forgot to mention that the "old" version of the file is 21kB and the new one only 4kB.

I wonder what other rubbish was in the old one??