Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wannan tattunawa ta zama daɗaɗɗiya. Yi sabuwar tambaya idan ka na bukatar taimako.

Some websites dont show text properly but only in Firefox

  • 4 amsoshi
  • 4 sa na da wannan matsala
  • 484 views
  • Amsa ta ƙarshe daga Scott

more options

Firefox isnt showing text on certain web sites, all I get are pipes |, arrows < >, dots etc. yet I can view the pages fine in Chrome or IE. Iv removed my FF theme, disabled add ons and checked if everything is updated and still nothing.

Its really annoying, the main site I have a problem with is http://www.three.co.uk but I just came across this site as well http://css-plus.com/examples/plugins/PlusSlider/ there have been others in the past but i just ignored it for a while but now its annoying me! 99.99% of sites are absolutely fine and if I disabled the stylesheets I see the text fine but of course it is all left aligned etc.

Mafitar da aka zaɓa

Try to disable hardware acceleration in Firefox.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

You can also try to uninstall Windows update KB2670838 if you have this update.

Karanta wannan amsa a matsayinta 👍 0

All Replies (4)

more options

This is what the Three website footer looks like and its the same sort of text I get on other problem sites.

more options

Zaɓi Mafita

Try to disable hardware acceleration in Firefox.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

You can also try to uninstall Windows update KB2670838 if you have this update.

more options

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Hi, thanks for the responses. I tried safe mode and the problem was resolved but I had already tried disabled plugins and that didnt seem to resolve the issue so I tried unticking the "Use hardware acceleration when available" in...

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

...and its fine now. I dont know what else this affects but its working fine so that'll do for me!

Many thanks for all your help.

Scott