Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wannan tattunawa ta zama daɗaɗɗiya. Yi sabuwar tambaya idan ka na bukatar taimako.

I upgraded Firefox to 4.0.1 and now the browser won't load

  • 5 amsoshi
  • 4 sa na da wannan matsala
  • 9 views
  • Amsa ta ƙarshe daga alan_r

more options

After upgrading to 4.0.1, the browser crashed unexpectedly. Afterwards, the browser won't open when it is run or clicked on. When I go to the task manager, it will say that the process is running and if I have clicked on the icon multiple times, there will be multiple processes. Restarting my computer does nothing.

After upgrading to 4.0.1, the browser crashed unexpectedly. Afterwards, the browser won't open when it is run or clicked on. When I go to the task manager, it will say that the process is running and if I have clicked on the icon multiple times, there will be multiple processes. Restarting my computer does nothing.

All Replies (5)

more options

Try Firefox Safe Mode>Hold down Shift key as you double click on Firefox icon. Don't check any boxes.

Try temporarily disabling your anti-virus and your firewall.

Report back.

more options

Tried that and it still won't load. It got as far as the prompt that has all the boxes. After that, nothing happened.

I should also point out that when I reinstall it, it does a compatibility run on some add-ons, and when it does so, it inevitably freezes.

An gyara daga thelaughingfool

more options

Did you click on "Continue in Safe Mode" to actually run Firefox in Safe Mode? See the Diagnose Firefox issues using Troubleshoot Mode article.

See also Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems for next steps, whether or not Firefox runs in Safe Mode.

An gyara daga AliceWyman

more options

Still not working. Am I just going to have to resign myself to using an older version?

more options

If you are working in a a corporate situation - Is anyone around you using Fx4 successfully? If Firefox is permitted you should ask your administrator to make sure Fx4 is cleared by your firewall.

With many "domestic" firewalls you need to give new permission for new versions.

You'll notice in Alice Wyman's article that you can try a version of Safe Mode(I'm not sure whether it disables Hardware Acceleration) if you can get to the first page(after closing down any firefox running via Task Manager) you can try >Firefox orange button >Help >Restart with Add-ons disabled. Then you try her other suggestions.

After that you would probably need to do an uninstall/re-install and try a new clean profile.

An gyara daga alan_r