Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wannan tattunawa ta zama daɗaɗɗiya. Yi sabuwar tambaya idan ka na bukatar taimako.

I can't delete my history. The "clear recent history" tab in tools is inactive.

  • 3 amsoshi
  • 153 sa na da wannan matsala
  • 24 views
  • Amsa ta ƙarshe daga dcasper

more options

I can't delete my history. The "clear recent history" tab in tools is inactive.

Mafitar da aka zaɓa

I am not in "private browsing" but "sop privare browsing" and "clear recent history" are still grayed. I am trying to delete all history. Is there more than one way to do so?

Karanta wannan amsa a matsayinta 👍 0

All Replies (3)

more options

That probably means that you are in Private Browsing - Use Firefox without saving history mode.

In Private Browsing mode some menu items are disabled (grayed) and some features like visited links and others are disabled and not working. You are in Private Browsing mode if you see "Tools > Stop Private Browsing" See Private Browsing - Use Firefox without saving history and http://kb.mozillazine.org/Issues_related_to_Private_Browsing ..... You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" To see all History settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history Uncheck: [[ ] "Automatically start Firefox in a private browsing session"

more options

Zaɓi Mafita

I am not in "private browsing" but "sop privare browsing" and "clear recent history" are still grayed. I am trying to delete all history. Is there more than one way to do so?

more options

for MAC OSX users: in order to delete your entire (6 months +) Firefox history for good I discovered you can go to the "places.sqlite" folder by pasting this link directly into your spotlight search engine and or go to "Library/Application Support/Firefox/Profiles/mbilmx5r.default/places.sqlite Then you want to drag "places.sqlite" and "places.sqlite-journal" into the "Trash" then restart Firefox. The files automatically recover themselves but they are clear of any history and all of the bookmark links are inactive. Just return to the "Bookmarks" tab at the top of your screen and open the "Bookmarks" then "Organize Bookmarks" then simply delete them by hand. GONE!!