Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wannan tattunawa ta zama daɗaɗɗiya. Yi sabuwar tambaya idan ka na bukatar taimako.

How do I turn off all hover pop-ups?

  • 2 amsoshi
  • 1 yana da wannan matsala
  • 60 views
  • Amsa ta ƙarshe daga SunSpirit13

more options

So, hovers are proliferating across all sites. They've gotten so bad now that I can't do anything without stupid crap popping up covering up what I'm trying to do. Tooltips, navigation menus, videos starting on hover, you name it. It's GARBAGE user experience, and I can't understand why anyone thinks this is okay. They're popping up everywhere all the time, 99.9999% of the time when I don't want it. It makes complex sites like Amazon totally miserable to even try to use for someone like me who's easily distracted.

So, I desperately need a solution at this stage. The internet is a graveyard of sites I can't visit because they drive me up the wall and ruin my day.

Someone previously recommended adblockers for this, but I use three adblockers (like I said, easily distracted by garbage), and none of them kill hovers.

How do I make hovers stop activating content and instead ONLY work on-click. Thanks!

All Replies (2)

more options

Pop-ups that open on hover are opened via CSS or JavaScript, so it isn't possible to block such pop-ups easily.

Note that your Mac OS should support the current Firefox release (88).

Any reason why you use Firefox 66 ?


(sorry for the previous reply; was meant for another thread)

more options

cor-el said

Any reason why you use Firefox 66 ?

(sorry for the previous reply; was meant for another thread)

Firefox 67 introduced some nasty problems, which I assume Firefox tried to correct with 68. In the interim, I returned to 66. By the time I decided to upgrade again, the Firefox interface had turned to absolute crap (IMO), and now I can't upgrade without losing all of my bookmarks it seems, so I'm stuck on 66.

I guess all we can do is hope this hover fad dies sometime before I throw my computer against a wall.