Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adobe Flash 11 doesn't work on Firefox 11

more options

I always used Firefox 11 without problems due to plugins (just my crappy hardware), but when I updated to newer version of Flash Player, nothing worked anymore on Firefox, but in Chrome everything goes perfect. I've also tried to reinstall the plugin, the stable and also the beta version, using Flash-Aid but nothing worked. Is there another solution to fix this issue?

Thanks from Italy!

I always used Firefox 11 without problems due to plugins (just my crappy hardware), but when I updated to newer version of Flash Player, nothing worked anymore on Firefox, but in Chrome everything goes perfect. I've also tried to reinstall the plugin, the stable and also the beta version, using Flash-Aid but nothing worked. Is there another solution to fix this issue? Thanks from Italy!

Chosen solution

I solved my problem! Probably, Adobe has deprecated the support for all those applications which run under Linux which aren't Google Chrome (I personally hate it). To solve it you have to rename and move the Chrome plugin into Firefox directory, in order to do this you have to:

1) Open a shell and move to Chrome directory (obviously, you have to install Chrome first) with the following command:

cd /opt/google/chrome

So you have to aim for "libgcflashplayer.so" file, and rename it to "libflashplayer.so", in order to make Firefox look correctly for the plugin. To copy the file (always by using the shell) you have to run:

sudo cp libgcflashplayer.so libflashplayer.so

2) Once you've made a copy with a different name of the same plugin, you have to move it into the correct folder of Firefox, everything will result into the following command:

sudo mv libflashplayer.so /usr/lib/firefox-11/

3) Then, set your shell to work in this other directory by running:

cd (to get out the old path) cd /usr/lib/firefox-11/

So, copy the file into the "plugins" folder by using:

sudo cp libflashplayer.so /plugins

4) Run Firefox and enjoy your Flash Player be working again!

Read this answer in context 👍 6

All Replies (7)

more options

You may have downloaded the incorrect version, as there is one version for Firfox & another for all other browsers. In any case the following references how to test, manage, update, and verify flash & associated plugin.

Update Flash:

The latest version of the Flash plugin should perform better and crash less often. To check if Flash is up to date, visit Mozilla's Plugin Check page. If it says that Flash needs to be updated, install the latest version manually using the steps below.

1. Go to the Flash Player download page at [Adobe.com] and download the Flash installer.

2. When prompted, save the file (i.e.install_flash_player_"version"_linux."processor".tar.gz).

3. At the top of the Firefox window, click on the File menu and select Quit.

4. Open a Terminal window (in Gnome, click on the Applications menu, select Accessories, and then select Terminal.)

4.In the Terminal window, change to the directory where you saved the file you downloaded (e.g. cd /home/user/Downloads).

5. Extract libflashplayer.so from the file you downloaded with the command tar -zxvf install_flash_player_"version"_linux."processor".tar.gz.

6. As the super user, copy the extracted file, libflashplayer.so, to your Firefox installation directory's plugins sub-directory. For example, if Firefox is installed in /usr/lib/mozilla, use the command sudo cp libflashplayer.so /usr/lib/mozilla/plugins and then enter your super user password when prompted.


Also see:

Flash Plugin - Keep it up to date and troubleshoot problems

more options

I've reinstalled once again the 32-bit version of the plugin completely manually, but didn't solved the problem... I also updated MozPlugger to the newer version available by compiling the source that you can found on their site (mozplugger.mozdev.org), but nothing changed... Any other possible fix?

Thanks again!

more options

Chosen Solution

I solved my problem! Probably, Adobe has deprecated the support for all those applications which run under Linux which aren't Google Chrome (I personally hate it). To solve it you have to rename and move the Chrome plugin into Firefox directory, in order to do this you have to:

1) Open a shell and move to Chrome directory (obviously, you have to install Chrome first) with the following command:

cd /opt/google/chrome

So you have to aim for "libgcflashplayer.so" file, and rename it to "libflashplayer.so", in order to make Firefox look correctly for the plugin. To copy the file (always by using the shell) you have to run:

sudo cp libgcflashplayer.so libflashplayer.so

2) Once you've made a copy with a different name of the same plugin, you have to move it into the correct folder of Firefox, everything will result into the following command:

sudo mv libflashplayer.so /usr/lib/firefox-11/

3) Then, set your shell to work in this other directory by running:

cd (to get out the old path) cd /usr/lib/firefox-11/

So, copy the file into the "plugins" folder by using:

sudo cp libflashplayer.so /plugins

4) Run Firefox and enjoy your Flash Player be working again!

more options

Note a comment /forums/contributors/708233?page=2#post-46006

"Your browser is blocking Flash" - A change to Flash last week makes some flash version detection methods break. This affects Yahoo mail (also Att mail and others that are based on Yahoo). The solution is to switch to "classic mode" in the email program. 

I am not sure that is directly related to your problem, but the info may be of use to some who read this thread and are having problems with Flash use.

more options

why does Adobe come up with a fckn plugin ever so often that doesn't work on Firefox?? I refuse to be FORCED to use Chrome!!!

Modified by TexDad

more options

FireFox 13.0.1 / Flash Player Plugin 11.3.300.265 (as of July 11, 2012)

The cause of the problem, in my case, was the Real Player Record Plugin found in the FireFox Extension window.

FireFox already disabled the plugin because it caused stability issues, but even in the "disabled" state (showing as greyed out), it still affected FireFox.

I went into Real Player, Clicked "RealPlayer - Preferences - Download and Recording" and in the right window of the preferences dialogue, uncheck the box on the line that says: Enable Web Downloading & Recording For these installed browsers.

Click "Ok" in Real Player and close it.

Restart FireFox, check the extensions window to see the plugin is gone.

Try YouTube and Flash works just fine.

Real Player caused the problem even though FireFox said it was disabled. The plugin has to be removed.

Any other plugins or extensions that are greyed out for similar stability reasons, get them removed.

more options

moderator locked this thread - it is marked as solved for the owner and was about Firefox 11 - thread is outdated as the problem between Firefox 13 and Flash 11.3 are caused by something entirely different