Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

latest version of firefox is incompatible with pdf plugins - how to read online pdf files?

  • 1 reply
  • 6 have this problem
  • 1 view
  • Last reply by cor-el

more options

Since 5.0.1 update of Firefox, I can no longer open or read online pdf's. Firefox indicates that plug-in is disabled and offers no substitute. All kinds of sites, including all of my banking, uses online pdfs which I can no longer open or read.

Since 5.0.1 update of Firefox, I can no longer open or read online pdf's. Firefox indicates that plug-in is disabled and offers no substitute. All kinds of sites, including all of my banking, uses online pdfs which I can no longer open or read.

All Replies (1)

more options