Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Advanced Search fails when using Firefox.

  • 3 replies
  • 0 have this problem
  • 4 views
  • Last reply by zeroknight

more options

I am using Firefox version 119.0.1 (64-bit) on Ubuntu 22.04. Using this version of Firefox, as well as previous versions for the last few months, I am having a persistent error when using Google Advanced Search. I enter search criteria into the field “Find pages with … all these words” and successfully progress through a chain of web pages. Previously I was able to backtrack to the previously mentioned field and find my search criteria, then edit the text, and carry out a modified search. For many months this field has been blank when returning to it. So it is now necessary to re-enter all text for a new search. This is very frustrating. I have experienced this problem on the three computers that I regularly use.

I have found that when I use the Google Chrome browser the problem goes away and searches progress normally. I would much prefer to use Firefox as my browser as I find its bookmark system superior. The truth is that if this problem with Firefox can’t be fixed soon I will be forced to migrate to Chrome. Can you please help me resolve this Firefox problem?

I am using Firefox version 119.0.1 (64-bit) on Ubuntu 22.04. Using this version of Firefox, as well as previous versions for the last few months, I am having a persistent error when using Google Advanced Search. I enter search criteria into the field “Find pages with … all these words” and successfully progress through a chain of web pages. Previously I was able to backtrack to the previously mentioned field and find my search criteria, then edit the text, and carry out a modified search. For many months this field has been blank when returning to it. So it is now necessary to re-enter all text for a new search. This is very frustrating. I have experienced this problem on the three computers that I regularly use. I have found that when I use the Google Chrome browser the problem goes away and searches progress normally. I would much prefer to use Firefox as my browser as I find its bookmark system superior. The truth is that if this problem with Firefox can’t be fixed soon I will be forced to migrate to Chrome. Can you please help me resolve this Firefox problem?

All Replies (3)

more options

This was fixed in version 120 (Bug 1850335).

Helpful?

more options

Just updated to Firefox snap in Ubuntu to 120.0.1 (64-bit). That alone did not fix the problem. I then followed discussion on bug 1850335 and saw suggestion to set docshell.shistory.bfcache.ship_allow_beforeunload_listeners = false This seems to have corrected the problem me. Thanks for the lead.

Helpful?

more options

It works for me on version 120.0.1 with docshell.shistory.bfcache.ship_allow_beforeunload_listeners set to default true.

Can you reproduce this in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.