Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox no longer able to open SharePoint documents in app - "one of the following protocols (ms-word) isn’t associated with any program or is not allowed"

more options

I've been using Firefox for many months and rarely had issues with this, but I've been unable to open documents from SharePoint to the MSFT apps on my computer for the last two weeks. When I have a SharePoint link that I need to open, one of two things happens: - if I right-click on the link and select "open in Word" (or whatever MS product I need), I get the following error message: "Firefox doesn’t know how to open this address, because one of the following protocols (ms-word) isn’t associated with any program or is not allowed in this context. You might need to install other software to open this address"

- If I open the document in the browser and then select "Open in app," it indicates that the app has been opened but nothing happens.

Any ideas on how to fix this?

I've been using Firefox for many months and rarely had issues with this, but I've been unable to open documents from SharePoint to the MSFT apps on my computer for the last two weeks. When I have a SharePoint link that I need to open, one of two things happens: - if I right-click on the link and select "open in Word" (or whatever MS product I need), I get the following error message: "Firefox doesn’t know how to open this address, because one of the following protocols (ms-word) isn’t associated with any program or is not allowed in this context. You might need to install other software to open this address" - If I open the document in the browser and then select "Open in app," it indicates that the app has been opened but nothing happens. Any ideas on how to fix this?

Chosen solution

I tried each of your ideas and had no success before the holidays, but came back from vacation and it had mysteriously fixed itself. I wish I could identify which solution made the difference, but regardless thank you all for your help!

Read this answer in context 👍 0

All Replies (4)

more options

Perhaps this is already set up, but just in case:

You could try creating a new preference for ms-word and see whether that helps. Here's how:

(0) Select (triple-click is fastest) and copy this new preference name

network.protocol-handler.external.ms-word

(1) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, paste the new preference name

If this is already set up, Firefox should show a bar for the preference with either true or false. If it is false double-click it to switch it to true. If you don't see that bar:

(3) Firefox should show a bar with the choices Boolean, Number, and String. Click Boolean then click the + button at the right end of that bar.

(4) If Firefox doesn't set the value to true automatically, double-click the new preference to switch the value to true

Does Firefox handle the links any better now?

more options

You might want check that a Windows update hasn't changed your protocols.

Change the way online templates are opened in Office https://support.office.com/en-us/article/Change-the-way-online-templates-are-opened-in-Office-067b5262-0e7c-44de-a2b0-f4a465e46777

more options

Chosen Solution

I tried each of your ideas and had no success before the holidays, but came back from vacation and it had mysteriously fixed itself. I wish I could identify which solution made the difference, but regardless thank you all for your help!

more options

We're glad to hear that you made it back safely and that you're up and running again.

Browse Safe!