Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In Firefox 52.02 is default browser yet Links from e-mail wont open

  • 1 reply
  • 1 has this problem
  • 6 views
  • Last reply by Shadow110

more options

I have Thunderbird as my email client and I have found the following problem with Firefox 52.02 on Windows7 x32.

When I hit the F1 key or click help in Photoshop CS4, if Firefox is running, it calls up the Firefox manager rather than sending the URL link to the running browser session.

I found a suggested solution which said to change the default browser to IE which I did. I even rebooted the computer just to make sure everything was cleared out of memory.

Now, if I click a URL link in Thunderbird, the link opens IE, but when I click help or the F1 key in Photoshop CS4, it still calls Firefox which opens the profile manager since I have several profiles.

Another quirky thing I found is that if I run Photoshop with Firefox closed and press the F1 key; it calls up the Firefox profile manager. If I then elect to start Firefox from the Photoshop call, and then hit the F1 key in Photoshop, it will then send the link to the opened profile session as it should.


I did come up with this work around. It's not ideal due to a bit of inconvenience but it does help the issue.

I created a URL shortcut link on the desktop that when clicked, calls up the browser session manager.

When the browser is started from this link, the URLs clicked in external programs, including the F1 Help call in Photoshop CS4, go to the current running browser session window as it is expected to do.

It turns out that this is a Firefox issue and has been around for awhile.since Firefox 30 but was supposed to have been fixed. I bet the guy who fixed the bug will be upset that someone put it back in.

https://support.mozilla.org/en-US/questions/1004390

All Replies (1)

more options

HI, thinking you have Win 7 issues and not Firefox issues. Not having high hopes of this fixing much in WIn 7 but Please try from a search Cmd.exe Dos Command Prompt and Right Click and run as a Administrator. Copy/Paste sfc /scannow and Enter. ( sfc<space>/scannow ) Reboot after.

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 52,8,1esr with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.