Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook is sending push notifications despite not being an approved website.

  • 5 replies
  • 4 have this problem
  • 25 views
  • Last reply by XenonBloom

more options

I am currently receiving push notifications from Facebook messages, which can be annoying because they pop up over my active window regardless of whether or not it's Firefox. I thought I may have accidentally enabled Facebook to send the notifications, but when I checked the list of enabled websites in the options menu, it's blank. Facebook isn't listed as an approved website, which means that I can't remove them from the list, and so I'm stuck receiving push notifications from Facebook with no way to disable them.

Is there any way to wipe push notifications clear, or to disable them completely?

I am currently receiving push notifications from Facebook messages, which can be annoying because they pop up over my active window regardless of whether or not it's Firefox. I thought I may have accidentally enabled Facebook to send the notifications, but when I checked the list of enabled websites in the options menu, it's blank. Facebook isn't listed as an approved website, which means that I can't remove them from the list, and so I'm stuck receiving push notifications from Facebook with no way to disable them. Is there any way to wipe push notifications clear, or to disable them completely?

Chosen solution

Facebook's help articles mention notifications for Google Chrome on desktop, but not for Firefox: Notification Basics & Settings | Facebook Help Center. Hmm...

What if you temporarily disable the notification feature entirely:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) Double-click the dom.webnotifications.enabled preference to switch it from true to false

(4) Double-click the dom.webnotifications.serviceworker.enabled preference to switch it from true to false

I'm not sure how quickly that takes effect.

Read this answer in context 👍 1

All Replies (5)

more options

Any temporary permission sites have to use notifications should expire when you exit Firefox.

You also should be able to modify the permission by clicking the padlock icon in the address bar while on Facebook.

If there's no permission control on the drop-down/doorhanger on Facebook, then the site might be using some other technique. I wonder whether any site with a Facebook Like or share button can now notify you? That would be annoying.

more options

Do you have any add-ons which might be delivering the notifications? Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Diagnose Firefox issues using Troubleshoot Mode)

more options

I tried restarting Firefox before posting here, and it didn't solve the issue. I'm currently running Firefox in safe mode as per your instructions, but I'm still receiving push notifications, so it isn't one of my add-ons.

When I check in the Content settings, I have no sites enabled for push notifications. When I check the lock icon beside Facebook's url, it tells me that I have not granted them any special permissions.

Facebook is also the only site that I'm receiving push notifications from.

more options

Chosen Solution

Facebook's help articles mention notifications for Google Chrome on desktop, but not for Firefox: Notification Basics & Settings | Facebook Help Center. Hmm...

What if you temporarily disable the notification feature entirely:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) Double-click the dom.webnotifications.enabled preference to switch it from true to false

(4) Double-click the dom.webnotifications.serviceworker.enabled preference to switch it from true to false

I'm not sure how quickly that takes effect.

more options

That seems to have fixed it, at least in the short term. I still don't know why the push notifications were popping up, but at least they're stopped now.

Thanks!