Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 43 webm vp9 issue

  • 7 replies
  • 1 has this problem
  • 14 views
  • Last reply by ffnmg

more options

after upgrade firefox 43, i notice youtube videos not play vp9 anymore. youtube videos only play mp4;codecs=avc1.4d on me

im check it youtube/html5 page. MSE & WebM VP9 show it enable im check it about:config media.mediasource.webm.enabled section its show it true

so any idea for play it youtube videos with vp9.

im using windows 10 by the way

after upgrade firefox 43, i notice youtube videos not play vp9 anymore. youtube videos only play mp4;codecs=avc1.4d on me im check it youtube/html5 page. MSE & WebM VP9 show it enable im check it about:config media.mediasource.webm.enabled section its show it true so any idea for play it youtube videos with vp9. im using windows 10 by the way

All Replies (7)

more options

so? any idea?

more options

Any media related error messages in the Web Console (Firefox menu button or Tools > Web Developer)?

more options

On Windows 7, I get MP4, but I haven't been paying attention. Do you think it changed only since Firefox 43? The HTML5 support page looks happy (https://www.youtube.com/html5). ??

cor-el said

Any media related error messages in the Web Console (Firefox menu button or Tools > Web Developer)?

Nothing stood out for me (especially early when Google would have been deciding what to serve).

more options

cor-el said

Any media related error messages in the Web Console (Firefox menu button or Tools > Web Developer)?

no

more options

jscher2000 said

On Windows 7, I get MP4, but I haven't been paying attention. Do you think it changed only since Firefox 43? The HTML5 support page looks happy (https://www.youtube.com/html5). ?? cor-el said
Any media related error messages in the Web Console (Firefox menu button or Tools > Web Developer)?

Nothing stood out for me (especially early when Google would have been deciding what to serve).

yes its happen after upgrade firefox43 all codecs looks enable on youtube/html5

more options

I'm sure Google's scripts are testing for what video capabilities Firefox has and deciding what they think will work best. Maybe in their testing, they decided MP4 works better than VP9 in Firefox 43? Or maybe there's a glitch in their script? Unfortunately, Google's scripts tend to be very complex, so it's rare that I can follow them to a successful conclusion (usually it's just an hour of frustration).

more options

im changin my user agent script. set to firefox 45 and its working. youtube videos playin vp9 codec anymore. solved.

Modified by ffnmg